LTspice simulation on 4th order active bandpass filter using multiple feedback and Sallen-Key topologies didn't go as I expected

Thread Starter

Yourint

Joined May 18, 2021
13
First of all, thanks for reading this, I tried to replicate this research as my project (not aim to publish or anything just for study purpose)
Reference: https://www.iasj.net/iasj/download/ceca8bad4ee05e7c

Now I tried to guess and do what I can do about this circuit and the result is this (Multiple feedback)
the magnitude of the decibel seems weird and wrong compare to the original in the reference
I couldn't find the UA748cp spice model so I downloaded UA748 instead and moreover is that inside the file UA748, the name of the model is UA776H, so I guess it has a similar property?
I don't know what I'm wrong with this because I'm new to this kind of topic. I would really appreciate it if you could guide me. Thank you


This is the graph from my simulation in LTspice XVII
messageImage_1620489625093.jpg

This is the graph from the original one
1621352474238.png

I also wonder if anyone know what this (!) means?
1621352875182.png
 

Attachments

ericgibbs

Joined Jan 29, 2010
12,901
hi Y,
I created my own from a the web ,made a Auto Gen model [ not very tidy, but it works]
Used AC as 1v in order to the correct plot.
E
Tidied up..
 

Attachments

Last edited:

Thread Starter

Yourint

Joined May 18, 2021
13
One more thing I would like to ask is when I run the simulation in LTspice VXII the program keep processing for a very long time and it doesn't seem to stop, so normally I would click "ESC" to stop the process and the graph will show up. This won't affect the result right?
1621355854025.png
 

Audioguru again

Joined Oct 21, 2019
3,173
The resistor values are much too low for the very old uA776 opamp that has a low output current. It and the very old uA748 opamp have slew rate limiting of the high frequencies causing distortion.
Repeat the simulation with higher resistor values (reduce the capacitor values to match) and with a modern opamp.
 

Thread Starter

Yourint

Joined May 18, 2021
13
It doesn't work for me, but the result is fine, so never mind. Thank you so much both of you ericgibbs&crutschow. I will continue my work on Sallen-Key if there are any problems, I may ask it later. Don't worry, I will try to solve it by myself first. (Audioguru again Thanks I will try that later)

:D
 

ericgibbs

Joined Jan 29, 2010
12,901
hi Y,
Hope that Carl can come up withe reason for it not working outside my PC, I would like to know if there some error.
E
Using Win 10 32 Bit , LTSXVII
 

Thread Starter

Yourint

Joined May 18, 2021
13
Not the intention of my question.
My question is, why use the old 748 op amp in any form?
I'm quite new to this kind of thing, so I just look at the reference and I saw they use UA748cp so I just replicate them and try to get the same result.
 

Thread Starter

Yourint

Joined May 18, 2021
13
Somehow, the graph from the simulation of the Sallen-Key are quite weird, do anyone know what is the problem for this graph?
This is from my simulation in LTspice XVII
1621414084610.png

This is from the reference
1621414252702.png

or maybe... do I need to swap capacitor and resistor in the 2nd stage?
 

Attachments

Top