SPICE model error with Subcircuit model nodes as "Text" Instead of Unsigned Integer in Mindi SIMPLIS

Thread Starter

malli_1729

Joined Nov 28, 2012
30
Setup: MPLAB Mindi Simulator in SIMPLIS mode, *.mod model file of capacitor GRM31CC80G227ME11.

I have loaded(via model library addition or directly including using .INC file) a Sub circuit model of Capacitor(GRM31CC80G227ME11) to Generic capacitor part in Mindi Simulator and using it circuit.

The model definition is like this below

.SUBCKT GRM31CC80G227ME11 port1 port2 and uses port1, port2 inside the Model.

When i am running the model, i am getting error as "input file X:\folder\MIC24046_1V2_565khz.deck, line 3916: R100 port1 11 2.27e+5

An unsigned integer to represent a node number is expected at the location where 'port1' occupies. "

Some how, simulator is not accepting model to have Nodes as Text it wants it as unsigned integers. Any ideas how to solve this.

GRM31CC80G227ME11 spice model
 

eetech00

Joined Jun 8, 2013
3,210
Setup: MPLAB Mindi Simulator in SIMPLIS mode, *.mod model file of capacitor GRM31CC80G227ME11.

I have loaded(via model library addition or directly including using .INC file) a Sub circuit model of Capacitor(GRM31CC80G227ME11) to Generic capacitor part in Mindi Simulator and using it circuit.

The model definition is like this below

.SUBCKT GRM31CC80G227ME11 port1 port2 and uses port1, port2 inside the Model.

When i am running the model, i am getting error as "input file X:\folder\MIC24046_1V2_565khz.deck, line 3916: R100 port1 11 2.27e+5

An unsigned integer to represent a node number is expected at the location where 'port1' occupies. "

Some how, simulator is not accepting model to have Nodes as Text it wants it as unsigned integers. Any ideas how to solve this.

GRM31CC80G227ME11 spice model
In the last line of the file:

Change this:
R100 port1 11 2.27e+5
to this:
R100 port1 11 2.27e5
 

Thread Starter

malli_1729

Joined Nov 28, 2012
30
It works with no errors in LTspice.
LTspice is taking models with node names as Text(Without changing anything it will work), i have tested this many times prior also. Issue is with MINDi SIMPLIS. In this also If we change the Node names text to numbers models are getting imported.
I want to see any options in model file or simulator which can be changed to accept Models with node names as Text also.
 

Bordodynov

Joined May 20, 2015
2,995
malli_1729, you pervert the very ideology of the Simplis program. Its ideology is the use of simplified models, and you are trying to use a complex model.
 
Top