[Resolved] How do I load a code in the Flash of a C2000 Launchxl F28069m

Thread Starter


Joined Apr 25, 2019
I'm having difficulties loading my code in the flash of the F28069M to use it in standalone without connecting the USB.
The code compiles without any errors, I changed the project to load in the Flash according to what I've found online (changed linked cmd file, added "#pragma", "extern", "memcpy" and "InitFlash();"). I added the "LOAD_SIZE" function in the linker command file since there was none and the compiler gave me errors.

I set the S1 as follows: S1-1 L, S1-2 H, S1-3 H
in order to load the program (since it's the only possible configuration that activates the debugger and lets me communicate with the uC).

I know that to make it run from the Flash I have to set it on GetMode (H, H, L). But I don't know exactly when to change the switches, should I unplug the USB, change and connect the external power source? Should I change it when the USB is still plugged in? Do I have to press the reset button?
The code worked good when running from RAM, now when I load it in to the Flash nothing happens, no error messages from CCS, the memory gets erased and later the program gets loaded and that's it.

I couldn't find any kind of guide online for such a "simple" task so I'm asking for your help.

Attached is my project


IDE: Code Composer Studio Version:
Board: LAUNCHXL-F28069M
Debugger: XDS100v2
C2000Ware: 3.03


Thread Starter


Joined Apr 25, 2019
I uploaded an example that uses the flash, I programmed the uC with Uniflash and it worked.
I moved the entire project to the example project and it ended up working too. I don't know what the problem was with the old project.