Remote control by location (PIC in Oshonsoft)

Discussion in 'Embedded Systems and Microcontrollers' started by camerart, May 17, 2018.

  1. camerart

    Thread Starter Senior Member

    Feb 25, 2013
    1,024
    35
    Hi,
    I've just finished making the BASE TRANSMITTER PCB.

    Leds are flashing and I've added a the first module (HC-12) radio, which is transmitting and will be used for HSEROUT, initially for testing.

    Now I've got to get my programming bearings back, and add all of the modules. Let's hope those brain cells are still living :)

    C.
     
  2. camerart

    Thread Starter Senior Member

    Feb 25, 2013
    1,024
    35
    Hi,
    HC-12, BMP280 and AK8963C working.

    Here's the updated program:

    C
     
    W4GNS likes this.
  3. JohnInTX

    Moderator

    Jun 26, 2012
    3,438
    1,753
    @camerart
    Thanks for the update.
    Kudos! Well done!
     
  4. camerart

    Thread Starter Senior Member

    Feb 25, 2013
    1,024
    35
    Hi,
    TRANSMITTER MODE2:

    The RX receives signals from the GPS module and the REMOTE. At the moment I'm transmitting REMOTE signals via serial FTDI/HC-12. (The message has been changed from $BASE to $REMOTE)

    The signals are arriving at the RX, but the program isn't processing them. Any ideas please.

    _______________________________________________________________________________
    I'm going to use an broken Hitec Eclipse 7 from the past as the transmitter.

    Here is a photo of the innards. All of the joysticks, need to be centralised for this project, and as you know, the throttle is held by a friction spring, which I have removed. I have marked the joystick centralizing plate for the elevator, that I have to duplicate as best as I can for the throttle.
    C.
     
    Last edited: Mar 17, 2019 at 4:50 AM
  5. camerart

    Thread Starter Senior Member

    Feb 25, 2013
    1,024
    35
    Hi, TRANSMITTER:

    I'm testing the RX using only simulated REMOTE signals.

    I'm getting this result: Attached

    If I'm reading it correctly the first 1102 line is what's being SENT, and the second 1102 line with the marker is what's being processed. At the change point, the sentence isn't being updated, so I assume there's a timing issue.

    Any ideas how to fix this please?

    NOTE: The program changes slightly as I progress.
    C
     
    Last edited: Mar 17, 2019 at 3:46 PM
  6. camerart

    Thread Starter Senior Member

    Feb 25, 2013
    1,024
    35
    Hi, TRANSMITTER
    slight update on tests.

    Here's the result from HSEROUT's from the computer terminal.

    When the PCB and test REMOTE signal are first switched on, the signal is processed and shown on screen, then it doesn't process till I switch OFF the sending signal, on switch ON, it prcesses once, then no more.

    Also there are artifacts on screen which are a puzzle.

    NOTE: The program changes slightly as I progress.
    C.
     
    Last edited: Mar 17, 2019 at 3:47 PM
  7. camerart

    Thread Starter Senior Member

    Feb 25, 2013
    1,024
    35
    Hi,
    All 4x control joysticks sprung centralised.

    360 Deg Optical encoder fitted.

    C.
     
Loading...