Problems with SAMD4S with WILC1000 SD and example project from ASF

Thread Starter

Nick_01

Joined Dec 20, 2019
1
Hi,
I am trying to program a SAM4S board with a WILC1000 SD connected on its SD slot to act as an access point. I use Atmel Studio 7.0.2389 (also tried 2397, 1931, 1645 and 643). There are a lot of example projects in ASF for this combination of devices, but it turned out that almost all of them are for the extension board connected to SAM4S's EXT1 connector. The only project for the SD version of the module is WILC_SERIAL_BRIDGE_WILC1000_EXAMPLE. However, it does not seem to work also. When I start typing in the console, only grey rectangles appear; if I upload it with "Start debugging and break" and then "Break all", Disassembly view opens and shows "Memory out of bounds or read error".
Is there a (relatively easy) way to adapt one of the Mode_AP example projects for EXT1 to work for the SD module? If not, I tried searching for a EXT1-connectable WILC1000 extension board, but couldn't find one anywhere. What is the best combination of devices to use for developing a project with the WILC1000 chip?

Thank you in advance.
P.S. For communication in the future I plan to use SPI, but for now SDIO, which is the one enabled by default on the SD module, will be enough.
 
Top