FT232RL Chip is not working (USB to TTL)

Thread Starter

aiakon

Joined May 21, 2022
1
First of all this is an urgent question my project's deadline is coming closer. Please help me

I used FT232RL chip to make USB to TTL converter. I did this connection below. I can make serial communication but I cannot receive any message. I can also send message and TX Led is lightining up.

1653117215615.png
 

sagor

Joined Mar 10, 2019
696
Question is, what is the TXD and RXD driving? Does the USART expect TTL levels (5V) or 3.3V levels?
At 3.3V on VCCIO, your logic levels for TX and RX may be as low as 2.2V (typical 2.7V), which may not drive a true TTL load properly.
If driving a true TTL load with TXD and RXD, tie the VCCIO to VCC instead.
 

Jon Chandler

Joined Jun 12, 2008
194
Are the Rx/Tx connections correct?

Usually, this is correct:

Tx -------> Rx

Rx <------- TX

but sometimes, trying to be helpful, some devices are labeled as where they should connect instead of what they are.

Also, baud rate, parity, data bits, and stop bits need to be in agreement on both sides. If you see garbled characters, this is the next thing to check.
 

Picbuster

Joined Dec 2, 2013
1,038
First of all this is an urgent question my project's deadline is coming closer. Please help me

I used FT232RL chip to make USB to TTL converter. I did this connection below. I can make serial communication but I cannot receive any message. I can also send message and TX Led is lightining up.

View attachment 267747
Hi,
Compare drivers baudrate and handshake with rs232 connected device.
Look at you FTDI config data.
Check status handshake. All should be off. (rts/cts and for testing xon/xoff handshake also off)

Config tool available at ftdi

Picbuster
 
Top