Unable to run the a Triac simulation in LtSpice.

Thread Starter

K_Thewld

Joined Jul 25, 2017
9
I have searched online in attempt to see how I can setup my spice model to run a simulation on a triac. But I keep getting this error: "Unknown subcircuit called in: xu1 n003 n004 0 triac", I haven't been able to figure out how to get past this or found a simulation online. Anyone can help?
 

Alec_t

Joined Sep 17, 2013
14,379
Which version of LTspice are you using? Version XV11 on Windows looks for relevant models in the Users/User/Documents/.... path.
 

Alec_t

Joined Sep 17, 2013
14,379
Google 'triac spice model'. Download one or more models of your choice and save it/them in the ..../lib/sub folder.
 

Thread Starter

K_Thewld

Joined Jul 25, 2017
9
Which version of LTspice are you using? Version XV11 on Windows looks for relevant models in the Users/User/Documents/.... path.
My LtSpice is that version, XVII. Does that mean I have to set the destination to a specific triac model file? Is there anything as such in the LTSpice directories?
 

Papabravo

Joined Feb 24, 2006
21,261
I was able to get the .asc and .asy file. Not sure where I can get the subckt file. But in the mean time see what you can do with it.
Thanks in advance.
Your setup in incomplete. What you have is a schematic which uses the symbol defind in the .ASY file. What you lack is the necessary file that describes the operation of the TRIAC device. You should check on the Yahoo group for LTSPICE to see if they have one or alternatively see if the manufacturer has one.
Last thing to do is google for "TRIAC Spice Model"
Then follow the directions in the LTSPICE help file for adding subcircuits to your design.

Checkout this thread:
http://www.diyaudio.com/forums/software-tools/217669-triacs-ltspice-model.html
 

eetech00

Joined Jun 8, 2013
4,006
I was able to get the .asc and .asy file. Not sure where I can get the subckt file. But in the mean time see what you can do with it.
Thanks in advance.
Hi

The "SUBCKT" file is a file written in spice code that models the behavior of the part. In your case, it models the behavior of the TRIAC.
The spice code definition usually begins with the keyword ".subckt" followed by the device name. That's what is meant by "subckt" file. LTspice is complaining that it cannot find a file with a device name of "TRIAC" which is the name you've placed in the "Value" field of the TRIAC symbol on the schematic.

The spice model "subckt" file is missing on your schematic.

You'll need to decide on which specific TRIAC you want to use and then search the web for a matching spice model file.

eT
 
Top