Trying to troubleshoot a main board with Rockchip RK3288 microprocessor

Thread Starter

Yami

Joined Jan 18, 2016
242
Hi there everybody,
Sometime back I received a faulty guitar effects pedal board, it quite famous among the guitarist apparently. The unit does not boot up, goes through a start up sequence and just turns off. The main board is made up of Rockchip RK3288. Doing an internet search showed that a lot of people was going though the same situation. Nothing seems to get the unit to start back up - resetting etc.
The manufacture seems to not acknowledge this known issue and weren't very helpful. However I was able to source a spare board from the party which manufactures the main board.
Installing the new board rectified the problem, but after about three weeks the same thing happened. This time I was able to get it back to life by pressing the reset button, after couple of months it strikes again. This time however I was not able to get it back to life with the reset button. The guitarist it not really interested in reviving it anymore. So I thought I will just mess with just for my personal reference.
So as I said the microprocessor used Rockchip RK3288, the power management IC used is the ACT8846. I tried to find any obviously faulty components, couldn't find it. Going through the datasheet for the ACT8846 I found out that there was a way to manually reset the processor by shorting nPBIN to ground. I tried this but no difference. Start up sequence seems to work I even get 5V at the PWRHLD pin for a moment and it goes back to 0V. The nPBSTAT is used to fire an interrupt and it seems to be doing that as well. But the power doesn't latch. The button used to turn on the unit is one of those momentary push buttons which I assume fires some kind of an interrupt. If I press and hold this button, the voltage tends to remain at the pins for as long as I hold it.
I am quite new to troubleshooting circuits including microprocessors. Not having the schematic makes it that much harder. Just trying to 'solidly' figure out what the issue could be, even though I am not able to fix it. Any tips/help troubleshooting this would be greatly appreciated.
At this moment I am using the old mainboard with nothing else attached (buttons etc) only the 12V power supply.

Rockchip RK3288 datasheet -
http://webcache.googleusercontent.com/search?q=cache:http://opensource.rock-chips.com/images/4/4e/Rockchip_RK3288_Datasheet_V2.2-20170301.pdf
 

Attachments

Top