sic fet driving with opt sw

Thread Starter

brodonh2

Joined Jan 22, 2023
7
Hi All,
Thanks for being here.
I've been driving 16 sic fets with 2 drivers for a pulse motor and all is working well until I up the voltage to 60v battery power.
Usually one of the fet drivers fails and catches on fire at 60v. Runs fine at 36v.
I need some advice that will head me in the right direction.
I'm using the IXDI614PI /SI (inverted driver) it works well with the opto sw.
Better understanding of mosfet driver for these fets and better resistor choices is my need.
Thanks,
Donald
 

Attachments

crutschow

Joined Mar 14, 2008
34,415
All your verbal arm waving does little to explain how things are actually connected.
Post a complete schematic of what you have, as Ron suggested.
 

MisterBill2

Joined Jan 23, 2018
18,475
I see an optical interrupter data sheet, I hope that is not what is being used as an opto-isolator to drive the fets. FAST switching is required no matter what the device is, and using a slow device to drive the gate will not ever work.
In addition, heat sinking adequately is mandatory.
 

Thread Starter

brodonh2

Joined Jan 22, 2023
7
Hi All,
I made some changes to the driver board and now it's running well at 60v input.

The charge bank is being charged with flyback energy (700v spikes)
Banks are swapped at 3 minute intervals.
1 bank is 5, 750cca automotive batteries.
Close to the end of the vid there is a swap and one can see the bank meters reverse direction.
Short explanation at end of vid.
Concept is for extended run time with electrical generator running off the shaft.

Dropbox link to today's 60v run video and scope shot of driver pulse from one driver.
https://www.dropbox.com/scl/fo/4hzexwcvy5jn3irqs1uz2/h?rlkey=5fk8ivpqoq0yy791x2fbjx34h&dl=0

Donald
 

Attachments

Top