Replacing a 4 pin leaded inductor with a 2 pin

Thread Starter

gkmaia

Joined Dec 22, 2018
34
I am struggling to find a 4 pin replacement for my 560k H18 inductor.

I suspect any 2 leaded 58uH coil will do as the extra 2 pins are not doing much extra. But I could be badly wrong. Could anyone confirm before I do something bad?

What I got available here in Nz is a ELC09D560F - Panasonic 56 μH ±10% Ferrite Leaded Inductor, 1.1A Idc, 130mΩ Rdc ELC09D

I also have a complementary question. This inductor was making a very loud whine (pin points each component with a soundscope and it was screaming. What would usually make an inductor whine too loud? Inductor failure (how if it just a wire)? Surrounding components failing, capacitors, traces...? Power source issues?

Any help I appreciate.

IMG_2151.JPG IMG_9500.JPG
 

ericgibbs

Joined Jan 29, 2010
14,183
hi gk,
Looking a the second PCB image, it shows the copper track is linked and a symbol of the single inductor on the PCB.
Fit your two pin inductor in the holes as shown by the symbol.
The whining sound is due the high frequency switching current thru the inductor causing the winding to vibrate.
It is possible to use a thin layer of adhesive on the winding, that will help reduce the whine.
E

Update:
If you have some thin varnish paint, you can use that to coat the inductor, or some of your girl friends nail varnish.;)
 
Last edited:

Thread Starter

gkmaia

Joined Dec 22, 2018
34
hi gk,
Looking a the second PCB image, it shows the copper track is linked and a symbol of the single inductor on the PCB.
Fit your two pin inductor in the holes as shown by the symbol.
The whining sound is due the high frequency switching current thru the inductor causing the winding to vibrate.
It is possible to use a thin layer of adhesive on the winding, that will help reduce the whine.
E
Hi Eric,

Thanks for that. I will follow!

Cheers
 

AlbertHall

Joined Jun 4, 2014
11,608
The whining sound is due the high frequency switching current thru the inductor causing the winding to vibrate.
The high frequency in this inductor should be well beyond human hearing so any sound made should be inaudible.
In my experience of such supplies, this kind of noise is caused by some kind of instability imposing an audible frequency modulation on the inductor current caused by something other than the inductor. The capacitors are probably the first stop in hunting down the actual problem.
 

ericgibbs

Joined Jan 29, 2010
14,183
hi,
I am not suggesting that it is vibrating at the high frequency of SMPS switcher, but at a sub audible frequency, which I know from practical experience often happens, having designed and built a fair number of SMPS.
The cure I have that suggested ie: varnish is usually enough to kill the audible resonance.

EDIT:
This PDF may help you understand the cause of audible resonant noise.
 

Attachments

Last edited:

recklessrog

Joined May 23, 2013
985
Yes Eric is correct, I remember one particular Plasma tv that after a couple of years use, started to emit a horrible squeal. It was caused by a switching transformer in the power supply. There was a large batch that had not been properly vacuum impregnated with the varnish during manufacture.
The only cure for them was replacement. Another Tv had some similar chokes like the one in the photo that could become noisy, we cured this with a coating of quick dry varnish.
Who remembers the noisy transductors in Grundig televisions, and all the dry joints around the pins?
 

Thread Starter

gkmaia

Joined Dec 22, 2018
34
Will it do any harm if I try to turn the device on without this inductor? That would be a good test to determine if it was actually the source of the whining.
 

Thread Starter

gkmaia

Joined Dec 22, 2018
34
The high frequency in this inductor should be well beyond human hearing so any sound made should be inaudible.
In my experience of such supplies, this kind of noise is caused by some kind of instability imposing an audible frequency modulation on the inductor current caused by something other than the inductor. The capacitors are probably the first stop in hunting down the actual problem.
All the capacitors on the board have been replaced as they were failing. As you can see on the photos there is a lot of damage and traces fixed from several leaking capacitors.
 

AlbertHall

Joined Jun 4, 2014
11,608
Will it do any harm if I try to turn the device on without this inductor? That would be a good test to determine if it was actually the source of the whining.
I doubt it will do anything without the inductor so lack of noise wouldn't tell you anything.
 
Top