Need help with MPLAB X IDE Version 1.85 and Java. :(

Discussion in 'Embedded Systems and Microcontrollers' started by johnnyinwa, Sep 21, 2015.

  1. johnnyinwa

    Thread Starter Member

    Jun 24, 2013
    Heh guys,
    I had an older version of java (I think it was Version 1.7) on my windows vista pc. Anyway I upgraded to the newest version of java (I think it was version 1.8) so I could play an on-line game. Anyway I didn't like the game so I killed java thinking that the code wasn't needed. Anyway I have MPLAB X Version 1.85 on my computer for programming microcontrollers which was working fine until I started messing with java. Anyway I tried to run MPLAB X V1.85 after killing java and it said I needed java 1.6 or higher to run MPLAB X. I downloaded java 8 update 60 from oracle and installed it on my fixed disk thinking that would fix the problem. (The installed code was 20.6 MB.) Anyway now when I try to run MPLAB X V1.85 from my desktop the MPLAB X V1.85 boot window pops up and then it just turns off and MPLAB doesn't work. I do know that the current version of MPLAB X from Microchip is 3.1. Anyway my question is how do I get MPLAB X to work on my pc and keep the projects I have already made with MPLAB X? I could really use your help here guys -- as usual I am probably missing something really basic here.
  2. nsaspook

    AAC Fanatic!

    Aug 27, 2009
    Uninstall the old version of MPLAB X and install the new version. 3.1 has it's own Java files in the download.
    johnnyinwa likes this.
  3. johnnyinwa

    Thread Starter Member

    Jun 24, 2013
    Thank you so much for your help -- your fix worked! Once again you guys have come through for me. I love this site to death.

  4. takao21203

    Distinguished Member

    Apr 28, 2012
    The old versions only run with certain java revisions.
    And have serious bugs.

    You should get the latest compilers as well.