INVERTER WELDING IGBT SECTION BLOWN

Thread Starter

Ravdenver

Joined Sep 29, 2019
6
Good day everyone, I have a Inverter IGBT welding machine here with 4 -1MBH50D-060S. Before the 4-IGBT are blown including rectifier which is GBPC 5008. I finish replaced all 4- Transistors and rectifier diode. After I powering my machine, power is good without a light of error indicator, but when I touch the torch to the ground the transistors are blown again. Any recommendations to check parts is appreciated!
 

Thread Starter

Ravdenver

Joined Sep 29, 2019
6
IMG_20190930_215120.jpg
Here is the diagram of my welding machine. The transistors circled with red pen are the parts that always blown after the welding rod touch to ground.
 

Janis59

Joined Aug 21, 2017
767
Just idea, how if the current loop shows current readings all the time too small? Then UC3856 will generate excessively long pulses what will kill the time-gap between four phases waves. Other idea - minor part of power transistors, or their driver transistors, or power diodes - all what on the radiator, have broken mica insulator plate thus the contacting with mainboard i.e. gnd. Third idea, if feel 100% sure that none of said, then UC3856 may be faulty, however the driver transistor defect is much more probable. Take oscillo and read the waveforms on main igbt gates, the picture will be a key for understanding the true. To save the next igbt, may disconnect the igbt section at measurement time.
 

Thread Starter

Ravdenver

Joined Sep 29, 2019
6
Appreciate your ideas, actually I didn't suspect uc3856 i just only focus in radiator e.g. the transistors gate parts including resistors, zener diode, capacitor and I discover that the 2 series zener diode is shorted, 1 capacitor is broken leg and the 1 mica insulator broken. By the way I don't have an ocilloscope and sadly after I check in power test. My tester blown due to wrong setting. I need to buy a new tester. I hope you always monitor this my thread for the result of my other test. Thank you for your kind and share your idea. Thank you you.
 

Thread Starter

Ravdenver

Joined Sep 29, 2019
6
I reading a thread regarding for blowing IGBT's transistors and all of this is recommended to use ocilloscope for measuring IGBT signals and voltage and now I wonder if I can successfully repair this machine by using of analog multi tester with out replacing and blowing again in third time.
 

Dodgydave

Joined Jun 22, 2012
8,374
Sounds like Over Current, try and input a dc voltage from 1 to 3V across the output of the Current bridge rectifier, to check if the current sense is working on the UC3856 chip, it maybe that the current sense transformer isn't giving enough voltage out, if so remove some of the resistors that are in parallel with the bridge rectifier R16-19.
 
Top