Driving IRF7201 MOSFET from digital output

Thread Starter

BurninBri

Joined Aug 16, 2011
30
I have a circuit with a pair of MOSFETs (one n-channel IRF7201 that is the input to drive a p-channel SSM6J507). It's supposed to be a gate to either turn on the output or turn it off. After reading several other threads on here about driving MOSFETs with digital outputs, I chose the IRF7201 because it has a Vgs(th) of only 1.0V. It's controlled by a TLC7705 which is supposed to sense when the voltage coming from a regulator is actually good or not and then wait a bit of time and create a reset signal to drive this output circuit. It's a bit weird since the circuit almost works. The output is 12V and works correctly, but when I put any load on it (about 1A load), the output drops to 2V or so which is exactly what I was trying to avoid. While the 7705 is supposed to be able to drive up to 10mA max, I have a feeling that in this configuration (with an external voltage divider, and also with some extra voltage dividers from the regulator) that the 7705 is not the right part for the job and I should have used a 7701. (The 7705 has an internal voltage divider in addition to all of these, and perhaps it has more going on inside of it as well). In any case, while I can swap out the 7705 for a 7701 and change the resistors, etc, I'm more concerned because it seems to take 38mA of current to actually turn on the output MOSFETs. I measured this by hooking it up directly to the 5V and measuring the current (voltage drop) across R22 (I replaced the 0-ohm with a 1.37k-ohm). The output circuit worked well when I hooked it up to a wire directly to +5 or ground (and it also even enabled the output after a while of being disconnected and allowing it to "float" high). Looking back at the datasheet of the IRF7201, I think I missed something that was pointed out in another thread here. It's that the 1V Vgs(th) is specified with a drain current (Id) of only 250uA. With R21 at 10K, I would have 1.2mA instead. So would I just be okay to replace R21 with a 48k resistor instead? I'll be trying that tomorrow. Anything else I should be concerned about? Thanks!
 

Attachments

LowQCab

Joined Nov 6, 2012
2,620
12-Volts through a 10K Resistor directly to Ground is only 1.2mA , not 38mA.

It may be that your TLC7705 has a Switched-Ground-Output which
is not capable of Sourcing-Current, and therefore your Circuit
only "appears" to be working "sorta-kinda" by accident.

Try installing a 10K "Pull-Up" Resistor on the Gate of the N-Channel-FET.
( 10K will NOT be adequate for any PWM, or high-speed-Switching )
.
.
.
 

Thread Starter

BurninBri

Joined Aug 16, 2011
30
Thanks so much for the suggestion. I tried it, but it didn't change the behavior. Note that I also changed R21 to be 48k, and that didn't change anything either. I looked into the 38mA to drive the MOSFET that I saw the other day and realized that I had measured that on a bad board and it's actually in the uA range; this would mean that the idea of a pullup resistor should have worked. However, it seems that the TLC7705 is doing something strange. The sample circuits for the TLC7705 don't show it with resistor dividers on there so perhaps something strange is happening when there is a divider network on there. Only the TLC7701 shows a divider network, so I'll try to swap it out for that next. Thanks again for your help and comments (or thanks to anyone else who has something to say about how we're doing this.)
 

BobTPH

Joined Jun 5, 2013
6,046
A MOSFET gate does not draw any current except for a short time when switching. It is driven by voltage. If the gate is drawing current in the steady state, it is damaged.

The output circuit (two MOSFETS) is fine, it should work.

Have you checked that the regulator can supoly your load directly? Perhaps the problem is there.
 
I agree with @BobTPH; the DC bias current should be virtually zero. Also, you don't need a pullup on the gate - the nRESET signal from U4 is a totem-pole output according to the data sheet. However, a weak pulldown might be beneficial here to make sure the mosfets are turned off until U4 starts operating normally.

By the way, why are you using such a huge mosfet at Q9? All you really need here is a garden variety logic-level small signal mosfet like 2N7001 or BSS138. Q9's saturated drain current should be tiny (12V/10K=1.2mA) in this case and Q9's Rds(on) is completely overwhemed by R21. Furthermore, you needn't worry about the Vgs(on) threshold. You have a 5V logic signal - that'll be fine.

As far as the TLC7705 having an internal divider, you'll need to take those into account using a little network analysis:

VSENSE = 4.55V
REQ(bot) = 750||(910K+290) = 461K

V12(thresh) = (461K + 422K) / 461K * 4.55V = 8.72V

So, if the input voltage from the 12V regulator off-page drops below this value, your output will turn off. If you expect to draw anything more than a few hundred milliamps or so, your 12V regulator better be a switcher otherwise you'll end up dissipating several watts by the time the voltage supervisor trips out.
 

Thread Starter

BurninBri

Joined Aug 16, 2011
30
@BobTPH, thanks for confirming that the circuit should be work correctly and indeed it works when the TLC77xx is taken out and I manually connect the circuit to 5V (or ground to turn off). As for checking that the regulator can supply the load, yes - that was my initial thought since the circuit seemed to be working with no load and not working with a load (standard load is less than 1A). However, it works fine with a load when manually connecting to 5V, and I also doubled up the load and tested it and the circuit powered both loads just fine. I did more checking on it today, and it seems to be something with the TLC77xx, but I can't figure it out just yet.

@allan.w.macdonald, thanks for the comment that we can use a much smaller MOSFET on Q9. I took this circuit from someone we had hired to do another board for us, but I was wondering the same thing myself when I started investigating this circuit more. (Note: turns out that person had issues with this circuit as well since he disconnected R20 in order to make it work; I didn't see that until I went and got one of those boards to look at to compare it to. That's fine in a 5V system but not in a 12V system!) Thanks also for your comment about not needing the pullup on the gate and letting me know about the totem-pole output. (I'll look at the pull-down. Thanks!) As for your voltage calculation, yes - I think I had used 8.75V as the desired threshold which was where I came up with these values (well, this was on round two since the first time I didn't realize the internal 910k and 290k).

I do have one question on a comment you made:
>>If you expect to draw anything more than a few hundred milliamps or so, your 12V regulator better be a switcher otherwise you'll end up dissipating several watts by the time the voltage supervisor trips out.
Could you clarify that? First, the regulator is a Buck-Boost (LTC3789) switcher, and we are using about 1A normally (but could go up to 2A). So we're probably good. But I was just asking what you meant by this for my own understanding. Thanks.

Other comments below:
Note that I thought that since the 7705 wasn't really made for having external resistor/divider network (since it has the extra 910k+290k inside and all the sample circuits show it directly connected and only the 7701 is shown connected to a resistor/divider network), I thought I would change the chip to the 7701. I did this, and it started working - even with a load. Yay! However, I hadn't swapped out the resistor network yet (it still had the 422k/750k in it), and it was sending the sense pin to be about/above 7V (it was about 7.3V) which is higher than the maximum rating of the chip. So I swapped out those chips with a 1.3M/182k network (for 9V threshold at 1.1V) and.... it didn't work again! It did the same thing it was doing before with the 7705. (And yes - the sense pin was at 1.47V or so but it just wasn't turning on.)

This was pretty frustrating, so I did some online digging and thought I found the issue after reading this post:
https://e2e.ti.com/support/power-ma...760/tlc7701---sense-threshold-voltage-setting
This post mentioned that we shouldn't be using resistors that are that large and it should only be 100x the input current. So I ordered some more resistors and tried again with 2.5k/18k... and it still didn't work. Same thing as before - the TLC7701 could drive the output to 12V when there was no load, but with a load the output would only be at 2.5V or so - which is clearly what we don't want going to the load and why we put that circuit on here in the first place.

I changed the resistor divider network to increase the voltage on the sense pin again to about 3.6V (using 422k/182k since I had those resistors), and it seems to work fine like this. It seems that the TLC7701 itself isn't actually driving the /RESET pin unless it's much higher than the 1.1V listed in the specification, unless there is zero load on the device (in which case it seems to be able to drive the /RESET pin fine as well until there is a load on the device). This is frustrating since it's now not set up to shut off at 9V (or 8.75V), and it's one of the reasons we put in this circuit (the other was to have a delayed start with a good rise time, which this still should have).

Thanks so much for your comments thus far. I'll put an oscilloscope on it soon just to see if I'm missing something. However, the /reset pin seems to be less than 1mV so it's probably not even being triggered at all. As for having 2.5V under load on the output of Q8, it could still be switching on and off there and perhaps that's due to a pull-down being needed at Q9 input? But if the TLC77x was working correctly it seems that shouldn't be needed. We're using a ceramic cap for C20 so it has no polarity. Other than that, any other thoughts on why the sense pin of the TLC770x doesn't seem to work unless it's driven much much higher than it needs to be? Any thoughts appreciated. Thanks so much.
 
Top