2n7000 spice model and datasheet mismatch

Thread Starter

cktboy

Joined Apr 24, 2020
11
hello,
I have plotted drain curve of 2n7000 spice model provided by onsemi(https://www.onsemi.com/products/discrete-power-modules/mosfets/2n7000) in proteus which is shown below. The value of drain current is Id=281mA when Vgs=5V.
2n7000 drain curve proteus.png

However, from the datasheet the drain current is Id=0.6A when Vgs=5V as shown below,

2N7000 drain curve values 2.png

The drain current value does not match between the spice model graph in proteus and the datasheet. Am I correct or is there something I am missing?
 

ericgibbs

Joined Jan 29, 2010
15,371
hi.
The only LTS model for the 2N7000 is in my last post.
I will download the link model and create a LTS model, post later.

E
 

5O5mm

Joined May 15, 2021
15
hi,
There is a problem, it is reporting unknown circuit nodes,

Perhaps you could try to create a LTS model.?

E
Hi ericgibbs I used the first model under the Simulation Models in the link. I think the problem is with the model. When we use X as prefix it accepts but when change it to M which is for mos devices, it gives an error. Also result doesn't seem to match with the one you used 2n7000.mod and the datasheet
 

Attachments

ericgibbs

Joined Jan 29, 2010
15,371
hi 505,
This is the one I built from the .mod I posted, using 'M' prefix, looks OK.

.mod header clip.
*2N7000/2N7002/NDS7002A at Temp. Electrical Model
*-------------------------------------------------
.SUBCKT 2N7000 20 10 30 50
*20=DRAIN 10=GATE 30=SOURCE 50=VTEMP

EG 1214.png
 

ericgibbs

Joined Jan 29, 2010
15,371
hi,
Used the link again, got the 1st on list ie: lib version
Changed extension to .net, used LTS to auto generate model, this is it, looks Ok.
E

Update: more detailed plot

EG 1217.pngEG 1216.png
 
Last edited:
Top