Welding Inverter Low Voltage Power Supply - Bypass Question

Thread Starter

Sosijdog

Joined Nov 11, 2009
12
Hi guys,
I have an MMA welder that needs repaired (Clarke AT132). The fault is that the low voltage circuit has failed in spectacular fashion. It is a flyback converter to provide the low voltage for the fan, main voltage relay and the inverter pulse controller.
Due to a shorted mosfet, there is significant damage to many smd components as well as the transformer.

Now in my limited wisdom, i thought that i could completely bypass the converter by using a stand alone power supply (18v dc laptop). The pulse controller uses a 15v regulator and i have used a 7812 voltage regulator to power the relay/fans. Powering this configuration up works perfectly on its own.

however, i then connected the power supply to the welder 240v input, thinkin that all would be well….
But once connected like this and power applied to the welder the RCD for the garage is taken out.
So my question is why? What am I missing?
I did find that the ground connector for the 15v regulator went to the -ve side of the bulk capacitor (330v DC here). Is this the cause? Would i require a seperate ground connection for this to work if at all?
But why would that have worked with the flyback configuration?

Now this welder is dirt cheap and not worth fixing really, but i wanted to try for my own curiosity.

But now i would like you guys to educate me as to why this doesn’t work.

What am I missing?
Thanks in advance… and go easy on me. ;)
 

sparky 1

Joined Nov 3, 2018
716
If you can post a picture of the inverter stick welder's main board/controller and some part numbers.
You can draw out what you think is there, It will be a switch mode and some other stuff. Then
probably a good photo will help to fill in the blanks. Clarke may be similar to other inverter welders that
provide the schematic like https://ozito.com.au/main/wp-content/uploads/2018/03/IWR-120-Online-Manual-Ed3.pdf
 
Last edited:

Thread Starter

Sosijdog

Joined Nov 11, 2009
12
Just another update guys - I have figured out what was wrong with my set up.

I had connected the earth wire from the power supply to the welder chassis earth point. i got a direct path from the negative dc rail direct to the earth connection.

Removing the earth bond from the power supply solved the issue. The welder now works perfectly.

:)
 
Top