Tx port dragged low

Discussion in 'General Electronics Chat' started by gdallas, Dec 8, 2014.

  1. gdallas

    Thread Starter Member

    Apr 25, 2012
    My Tx port on my PIC18f uart appears to be at an undesired constant logic “0” value and mycomms are failing. My status Led is constantly illuminated. I have tried changing this pin to an output and blinking the LED to test it, again LED just stays high however when I use my meter to test the voltage from this pins it does blink from 0-0.25V, something is keeping this logic as 0 and I cant see anything wrong in the hardware. Traces look ok on my board etc no obvious shorts.

    Any idea, could this be a dodgy PIC?
  2. Brevor

    Active Member

    Apr 9, 2011
    Possibly something on the Tx line is pulling it low. Posting a schematic would help.
  3. tshuck

    Well-Known Member

    Oct 18, 2012
    ...in addition to the schematic, post your code, there are numerous ways to mess up the initialization.
  4. gdallas

    Thread Starter Member

    Apr 25, 2012
    solved guys... i removed the 80pin SMD PIC and there was bridging underneath that i couldn't see.
  5. ErnieM

    AAC Fanatic!

    Apr 24, 2011
    Ammended post:

    One thing I do with large tight SMD chips is use an ohmmeter to check adjacent pins for shorts.
    Doesn't take too long to earn the warm fuzzy for this.

    Orginal post:

    Could be lots of things.

    First check there is no other function "default enabled" on that pin (though since you see a ghost of a signal I doubt thia one).

    Next divide and counque! Mechanically isolate that pin. If it is a DIP in a socket you just remove the chip and bend the pin out slightly. If it's a soldered down DIP think about cutting the trace(s), or cut the pin itself off, then later add a jumper for that pin. Even an SOIC can have one pin reflowed and pulled up a bit to isolate it.

    I'm not making odds on this one: could be a flakey output pin drive or something being driven that is a near short to ground.