Trouble with a Lincoln Welder control board

Thread Starter

JoeB2Q19

Joined Feb 6, 2019
7
Hi everyone,

My first post here hope I have posted in the right spot for this. I am working on a Lincoln WM250 Mig welder was last using it was working left it on for a couple hours while busy doing something else, when I came back and went to weld nothing no wire feed no gas valve.
I have checked all possible basic issues and have narrowed it down to the control board, No voltage to wire feed motor or gas valve. Best I have figured the board gets it power for the wire feed motor from a auxiliary winding made into the main transformer that its a Center tap coil witch outputs about 15Vac on each leg, each leg runs through a 120Z6 Metal Oxide Varistor / a resistor / large Cap / then to the part that I think failed a rectifier (FEP16GT) My question is on this component I am testing it like a diode with my DMM Pins 1 to 2 3 to 2 Pin 3 to 2 tests ok like any diode but 1 to 2 tests shorted.

Can someone tell me if I am testing this component correctly.

Thanks, Joe
 

MaxHeadRoom

Joined Jul 18, 2013
28,770
The two outer pins should appear as two diodes WRT the centre pin.
There should be a suffix that indicates the configuration of the two diodes.
CT, A or B
Non should show shorted from 1 to 2.
Max.
 

Thread Starter

JoeB2Q19

Joined Feb 6, 2019
7
Thanks for the reply Max it’s a CT positive case. So it sounds like I definitely have a bad rectifier. I know this is kind of a wave your magic wand question but what’s the chances that there is other damage downstream or up?

Thanks, Joe
 

Thread Starter

JoeB2Q19

Joined Feb 6, 2019
7
Thanks for the help I’ll get some coming looks like it’s going to be eBay all the typical suppliers are out of stock for some reason.

Thanks,
 
Top