[SOLVED] 3D UP Plus Printer "Motion System Error Y+" repair

Thread Starter

Siderites

Joined Dec 2, 2023
6
I have been using Tiertime's 3D printer UP Plus since 2012. This little beast worked fine until last week without any problem. Unfortunately, it started to reject printing requests by giving an "Motion System Error Y+" error.
When I looked at the user blogs of Tiertime, I saw that they usually had to replace the system CPU card (120USD) because of this error. This expensive method of repair didn't feel right to me. Because the system was initializing, and the other functions seemed to be fine. Only at the time of initialize, the 3D printhead was moving to the right and could not detect the starting zero point. However, it had to go to the left first and touch the switch to detect the starting zero point.
Therefore, I decided to check out the switch. The Y-axis switch was where I marked it with the blue arrow in the first picture. This switch, which is normally in ON (closed circuit) mode, was in the OFF (open circuit) state. When I replaced this switch, which is worth 1USD, my printer is back to normal and continues to write perfectly.

HIGHLY Snap Action Switch/Micro Switch SS-0505
 

Attachments

Ya’akov

Joined Jan 27, 2019
9,170
Welcome to AAC.

Limit switches are among the very first things to check since they are easy to test and generally very easy to get to. I am surprised there are no diagnostics that tell you there is a limit switch problem.

I would recommend, though, spending the extra few dollars to get an industrial grade switch since it is a critical component and gets many cycles.
 

Ya’akov

Joined Jan 27, 2019
9,170
I’ve added [SOLVED] to the thread title to make the nature of the post clear.
Thanks for posting a solution that might help someone searching.

—MODERATON
 
Top