Solar Simulator White LEDs flickering

Status
Not open for further replies.

Thread Starter

alatza

Joined Aug 16, 2019
4
Hello everyone,

I'm making a solar simulator with 13 white LEDs in series, they operate in 20V/450mA in full brightness (YUJI VTC Series LEDs 135L).

As a power supply I'm connecting 220V mains to a Variac, then to a full bridge rectifier and to 2x 400V/680uF capacitors in parallel.
Even with so much capacitance, when I increase the voltage on the variac, the LEDs start to shine around 210V, but when I reach 238V, about 70mA, the LEDs start to flicker and I can't reach maximum brightness.

I saw the ripple on the scope and is about 600mV peak-peak.

What am I doing wrong?

Thanks for any help.

Best,

Marcelo.
 

DickCappels

Joined Aug 21, 2008
5,936
From the forum's User Agreement:

  1. Restricted topics. The following topics are regularly raised however are considered "off-topic" at all times and will result in Your thread being closed without question:
    • Any kind of over-unity devices and systems
    • Devices designed to electrocute or shock another person
    • LEDs to mains
    • Any kind of jammers (ie - Phone jammers)
    • Rail guns and high-energy projectile devices
    • Transformer-less power supplies
    If You come across a thread or post discussing any of the above topics please report the thread so We can close, and if necessary remove, the offending thread/posts.
In other words, we are not permitted to discuss this kind of circuit, though you should be able to find other forums that allow discussion of this king of circuit.
 
Status
Not open for further replies.
Top