Remote Control repair

Discussion in 'The Projects Forum' started by wayneh, Nov 26, 2014.

  1. wayneh

    Thread Starter Expert

    Sep 9, 2010
    A friend has an old Radio Shack remote outlet control. It oddly will turn a lamp ON remotely, but will not turn it off. Any ideas?

    The 9V, handheld transmitter has separate buttons for "on" and "off". A small LED lights when either is pressed. Once the receiver's remote outlet latches on, repeated presses of the transmitter "on" button make no difference. And as I said, pressing the "off" button does nothing either.

    You can see in the photos that a Motorola encoder/decoder pair is used to send the message; MC145026 encoder and MC145027 decoder. A "valid transmission" output is produced when the right code is received and a nibble of data can also be passed. I don't see any other ICs smart enough to use a data nibble, so one thing I don't understand is how this thing differentiates between an "on" signal and an "off" signal.

    The receiver switches the outlet with a relay rated to 30A at 220V. It uses a transformer-less power supply - a capacitor (the big blue one) and diode followed by an electrolytic capacitor. There's also a zener diode nearby and I think that "regulates" the voltage for the rest of the circuit. There is evidence of heat aging in the vicinity of that zener, which is right next to the big electrolytic cap, both on the right hand side of the 2nd photo.

    I'm thinking of replacing that big electrolytic cap for good measure, but otherwise I don't have a clue how to proceed. I have no way to tell if the problem is at the transmitter or the receiver.

    IMG_0528.jpg IMG_0531.jpg

    Last edited: Nov 26, 2014
  2. Dodgydave

    AAC Fanatic!

    Jun 22, 2012
    Have a look at the datasheets, the decoder has data addresses on pins 1-7, so whichever pins are set on the transmitter ,the output switches on or off, it maybe the receiver psu is noisy or the R/C pin is at the wrong frequency, to see if the transmitter is working point it at a digital camera like your mobile phone and you will see the led flickering. .......
  3. jpanhalt

    AAC Fanatic!

    Jan 18, 2008
    I think the transmitter is RF.

    Perhaps it is a simple mechanical failure of the off button, or the latching relay gets stuck. Can you hear anything in the receiver when the off button is pressed?

  4. wayneh

    Thread Starter Expert

    Sep 9, 2010
    It's definitely RF. I tried to use a walkie talkie next to it to see if I could hear any signal, but that didn't work.
    The "off" button lights the LED on the transmitter, so it's not the switch itself.
    I think the relay per se is not stuck, but is receiving a stuck signal. In other words, it appears to be normally open and requires power to stay closed.
    Once on, the receiver is silent when the on or off button is pressed. It's not like it's trying to switch.

    One other oddity, if you are too close to the receiver, the relay won't latch "on" reliably and flops on and off as you hold down the "on" button on the transmitter. Back away across the room, and it switches and latches on just fine.
  5. bertus


    Apr 5, 2008

    The MC145027 needs two sequences of the same pattern to set the output.
    It can be that the receiver gets overloaded and does not send the correct values to the decoder.
    See the datasheet of the MC for more info.

  6. wayneh

    Thread Starter Expert

    Sep 9, 2010
    Seems to be the power supply, which should be easy to fix.

    I tried powering it with a separate 20V DC supply applied just past the AC coupling capacitor, where it normally "leaches" power off the AC plug, and it worked great. The relay clicks on and off and latches properly when using the remote switches.

    So now I just need to figure out which power supply parts are bad, or just replace all of them.

    Plugged in normally, there's 12.7V DC and 28.6V AC across the zener (using my cheap multimeter). It's 19.7V DC and 46.0V AC at the electrolytic capacitor, which is rated to 35V. Hmmm...

    The zener is a ZY27, voltage 25.1-28.9V. So the reading I get makes sense.
    Last edited: Nov 28, 2014
  7. wayneh

    Thread Starter Expert

    Sep 9, 2010
    Success!! (doing hamster dance, woot woot) :D It works fine now.

    I replaced 3 parts; the rectifying diode and the 2 largest electrolytic capacitors. I believe the diode and the largest cap were probably OK despite looking a bit charred by age. The 2nd largest cap on the PCB was definitely bad. It was rated 220µF and 16V while the biggest one was 330µF and 35V. My meter cannot measure capacity so I just time how long it takes the capacitor to discharge into my meter (1MΩ input impedance). The 330µF cap showed a nice slow discharge whereas the 220µF cap discharged almost as fast as the digits can change on the meter. I replaced it with a 330µF, 16V.

    This is the second device in a month that I've fixed by replacing a bad capacitor. I was once a skeptic about capacitor aging but I'm now a believer. Step 1 is still to look for obvious destruction, but my new step 2 is to test capacitors.
  8. GopherT

    AAC Fanatic!

    Nov 23, 2012
    Nice story. I had a unit that looked the same about 20 years ago. It came with a Sears garage door opener and worked on X-10 protocol. My wife wanted another one recently because she wanted a lamp inside the house to turn on when she came home (when the garage door opened). I discovered that RadioShack and Sears were the only to companies to latch onto the X-10 protocol in consumer products and they abandon that within a few years. She concluded a connecting a lamp to a digital timer was easier (and safer) than me finding a 25-year-old device from RadioShack.