problem with PSpice

Thread Starter

KFUPMer

Joined Nov 4, 2015
8
Hi guys,


I have used FilterLab to design 4th order Lowpass Butterworth filters , and I got this circuit :

upload_2015-12-5_20-30-49.png

and I got this Spice model :
Code:
* SUBCIRCUIT FOR SINGLE SUPPLY LOWPASS FILTER
* CREATED USING FILTERLAB ON 12/5/2015 AT 20:31:28
* |------------------------------------------------------------|
* |This model is being supplied as an aid to circuit designs.  |
* |While it reflects reasonable close similarity to the actual |
* |filter in terms of performance, it is not suggested as a    |
* |replacement for breadboarding. Simulation should be used as |
* |a forerunner or a supplement to traditional lab testing.    |
* |Neither this model nor any part may be copied without the   |
* |express written consent of Microchip Technology, Inc.       |
* |------------------------------------------------------------|
*
* 4TH ORDER BUTTERWORTH FILTER
* GAIN EQUALS 1
* CONNECTIONS:        INPUT
*             |    OUTPUT
*             |    |    POSITIVE POWER SUPPLY
*             |    |    |    NEGATIVE POWER SUPPLY
*             |    |    |    |
*             |    |    |    |
*             1    2    3    4
.SUBCKT FilterLab2     10   30   3    4


*************** Stage 1 ***************
R11    10    11    3570.000
R12    11    12    8660.000
C11    11    20    0.000000082
C12    12    0    0.00000001
X11    12    20    3    4    20    MCP6xxx

*************** Stage 2 ***************
R21    20    21    12400.000
R22    21    22    16900.000
C21    21    30    0.000000012
C22    22    0    0.00000001
X21    22    30    3    4    30    MCP6xxx

.ENDS

*Microchip Op Amp models are located on the Microchip website (www.microchip.com).
*See the User's Guide for general guidelines to selecting an Op Amp.
.SUBCKT MCP6xxx 1 2 3 4 5
*               | | | | |
*               | | | | Output
*               | | | Negative Power Supply
*               | | Positive Power Supply
*               | Inverting Input
*               Non-inverting Input
R1 1 0 1T
R2 2 0 1T
R3 3 0 1T
R4 4 0 1T
E5 5 0 POLY(1) 1 2   0 1T
R5 5 0 1T
.ENDS MCP6xxx

The problem here that when I want to use this model I got this error:
ERROR -- Incorrect number of interface nodes for X1
ERROR -- Incorrect number of interface nodes for X2



here is my Spice :
Code:
project

Vs 4 0 AC 1 sin(0 1 1k)

R1 3 4 3.57k
R2 1 3 8.66k
R3 2 7 12.4k
R4 7 5 16.9k

C1 3 2 0.082u
C2 1 0 0.01u
C3 7 6 0.012u
C4 5 0 0.01u

X1 1 2 2 FilterLab2
X2 5 6 6 FilterLab2


* SUBCIRCUIT FOR SINGLE SUPPLY LOWPASS FILTER
* CREATED USING FILTERLAB ON 12/4/2015 AT 22:42:19
* |------------------------------------------------------------|
* |This model is being supplied as an aid to circuit designs.  |
* |While it reflects reasonable close similarity to the actual |
* |filter in terms of performance, it is not suggested as a    |
* |replacement for breadboarding. Simulation should be used as |
* |a forerunner or a supplement to traditional lab testing.    |
* |Neither this model nor any part may be copied without the   |
* |express written consent of Microchip Technology, Inc.       |
* |------------------------------------------------------------|
*
* 4TH ORDER BUTTERWORTH FILTER
* GAIN EQUALS 1
* CONNECTIONS:        INPUT
*             |    OUTPUT
*             |    |    POSITIVE POWER SUPPLY
*             |    |    |    NEGATIVE POWER SUPPLY
*             |    |    |    |
*             |    |    |    |
*             1    2    3    4
.SUBCKT FilterLab2     10   30   3    4


*************** Stage 1 ***************
R11    10    11    3570.000
R12    11    12    8660.000
C11    11    20    0.000000082
C12    12    0    0.00000001
X11    12    20    3    4    20    MCP6xxx

*************** Stage 2 ***************
R21    20    21    12400.000
R22    21    22    16900.000
C21    21    30    0.000000012
C22    22    0    0.00000001
X21    22    30    3    4    30    MCP6xxx

.ENDS

*Microchip Op Amp models are located on the Microchip website (www.microchip.com).
*See the User's Guide for general guidelines to selecting an Op Amp.
.SUBCKT MCP6xxx 1 2 3 4 5
*               | | | | |
*               | | | | Output
*               | | | Negative Power Supply
*               | | Positive Power Supply
*               | Inverting Input
*               Non-inverting Input
R1 1 0 1T
R2 2 0 1T
R3 3 0 1T
R4 4 0 1T
E5 5 0 POLY(1) 1 2   0 1T
R5 5 0 1T
.ENDS MCP6xxx


.AC dec 100 10 40meg
.TRAN 0.01m 2m
.PROBE
.END
 

eetech00

Joined Jun 8, 2013
1,935
X1 and X2 should each have 4 pins in the call to Filterlab2 subcircuit

  1. X1 1 2 2 FilterLab2 <---not enough pins
  2. X2 5 6 6 FilterLab2 <---not enough pins
  1. X1 1 2 2 (pin4) FilterLab2
  2. X2 5 6 6 (pin4) FilterLab2
 
Top