LTSPICE problem with the CD40106 simulation

Thread Starter

a900892

Joined Dec 4, 2023
7
Hello, in a new design I am working with the CD40106 inverter Smichtt trigger and I have an important doubt. The output must be an output collector but in the simulation I can`t simulate this behaviour.
Could someone tell where is my fault? I would appreciate a lot. I post the simulation in the picture below.
I think that DISP and NEG must be inverted. With DISP I use a pull up resistor and with NEG I use a pull down resistor.
I don`t know where is the problem.
Thanks in advance.

1702064934645.png
 

Thread Starter

a900892

Joined Dec 4, 2023
7
It seems that the questio has some errors with the editor. I don`t understand why the signals DISP and NEG are not inverted.
Thanks in advance.
 

ElectricSpidey

Joined Dec 2, 2017
2,781
Well anyway...the reason the two outputs are not inverted in respect to each other is the fact that the CD40106 has push/pull outputs and those 10k pull up/down resistors will have little effect on the output voltage levels.
 

Thread Starter

a900892

Joined Dec 4, 2023
7
Hi a9,
Please post your LTS asc file.
Have you set the cd40106 VDD to 15V on its pop up window?
E
Hi Ericgibbs, thank you for your answer. I send you the .asc file. The VDD is 15V... and the pspice model is from the texas instruments web. I think that part is correct. If you detect something wrong please tell me...Thanks!!!
 

Attachments

eetech00

Joined Jun 8, 2013
3,953
It seems that the questio has some errors with the editor. I don`t understand why the signals DISP and NEG are not inverted.
Thanks in advance.
They ARE inverted. What wave forms did you expect?
:confused:
What are the resistors supposed to do?
:confused:
I guess I don't understand what you don't understand.
 

Thread Starter

a900892

Joined Dec 4, 2023
7
They ARE inverted. What wave forms did you expect?
:confused:
What are the resistors supposed to do?
:confused:
I guess I don't understand what you don't understand.
hi a9,
You do not require an external 15V supply.
Check this example.
E
Hi eetech00 and ericgibbs, i think that my error is owing to I have used the CD40106B because I can`t find the MC14106B from onsemi which is the original component in the circuit that I want to simulate. The MC14106B is an hex schmitt trigger with the output in opened collector but the CD40106B does not have this kind of output.
Sorry I will search another schmitt trigger, if exist some pspice model with opened collector output.
Thanks a lot for helping me, eetech00 and ericgibbs.
 

eetech00

Joined Jun 8, 2013
3,953
Hi eetech00 and ericgibbs, i think that my error is owing to I have used the CD40106B because I can`t find the MC14106B from onsemi which is the original component in the circuit that I want to simulate. The MC14106B is an hex schmitt trigger with the output in opened collector but the CD40106B does not have this kind of output.
Sorry I will search another schmitt trigger, if exist some pspice model with opened collector output.
Thanks a lot for helping me, eetech00 and ericgibbs.
Both CD40106B and MC14106B are not open collector.
 

Alec_t

Joined Sep 17, 2013
14,318
..... but if you ever need to simulate an open-collector* output you can use a diode on the output.

*Edit: or open-drain
 
Last edited:
Top