LTSpice Import .Model Problem - Doesn't Change Simulation

Thread Starter

alka2626

Joined Dec 16, 2015
2
I've received a model file for a Depletion mode, n-channel MOSFET from Microchip and imported it into my LTSpice circuit in the easiest way possible- basically copy and paste the .model file into LTSpice and then change the MOSFET's name to LND01 (the MOSFET type). See .txt file attached

I used the symbol "N-Channel MOSFET Transistor with explicit substrate" connection because the BODY needs to connect to the GATE, not the Drain. However whether I actually change the name of the MOSFET to LND01 or leave it at the standard NMOS, I'm getting the same simulation. (See attached .asc file)
Not sure if I'm importing the file incorrectly or the file doesn't work with LTSpice? I've read everything on the topic and not sure where to go from here...

any help would be great! Thank you!
 

Attachments

ronv

Joined Nov 12, 2008
3,770
I've received a model file for a Depletion mode, n-channel MOSFET from Microchip and imported it into my LTSpice circuit in the easiest way possible- basically copy and paste the .model file into LTSpice and then change the MOSFET's name to LND01 (the MOSFET type). See .txt file attached

I used the symbol "N-Channel MOSFET Transistor with explicit substrate" connection because the BODY needs to connect to the GATE, not the Drain. However whether I actually change the name of the MOSFET to LND01 or leave it at the standard NMOS, I'm getting the same simulation. (See attached .asc file)
Not sure if I'm importing the file incorrectly or the file doesn't work with LTSpice? I've read everything on the topic and not sure where to go from here...

any help would be great! Thank you!
Not sure if this helps, but remove the 3 volt source and replace with a 10K resistor. I'm not sure LTSpice is happy with it..but maybe.
 

Alec_t

Joined Sep 17, 2013
11,406
If you look at the error message that LTS pops up it tells you LTS supports version 3.3.0; not version 3.22 that your model is.
 

Thread Starter

alka2626

Joined Dec 16, 2015
2
If you look at the error message that LTS pops up it tells you LTS supports version 3.3.0; not version 3.22 that your model is.
Where did you see an error message? Mine runs fine but just doesn't do a simulation that correlates to the LND01... Is there a terminal I can look at in LTSpice where I can see the error message?
 
Top