Low Side MOSFET Gate Driver for 15A load current using totem pole (Push-Pull) configuration for battery operated?

Thread Starter

mishra87

Joined Jan 17, 2016
908
Hello,
I tried simulating MOSFET gate driver per below schematic and it is not working.
Does anybody having any proposal to build up mosfet gate driver ?
Since this battery driven circuit so there should not be any power consumption during if the machine is idle.
MOSFET : http://aosmd.com/res/data_sheets/AON7524.pdf (we can take this into consideration- i did not get this part in ltspice)
1616189014667.png

Regards,
 

Attachments

Last edited:

crutschow

Joined Mar 14, 2008
27,718
Please do not use colored fonts. It's distracting and makes the words hard to read.

How is it "not working".
When I say my car is "not working" does that tell you much?

It seems to work for me (below):
I used a substitute MOSFET as close to the one you selected that I had in my model file.
I reduced R1 to give the stated motor current (is it really 15A @ 3V?).
I also added an input stage to give a full 3V drive, since 2.5V is quite marginal for the gate voltage to fully turn-on the MOSFET.

1616211669198.png
 

Thread Starter

mishra87

Joined Jan 17, 2016
908
Please do not use colored fonts. It's distracting and makes the words hard to read.

How is it "not working".
When I say my car is "not working" does that tell you much?

It seems to work for me (below):
I used a substitute MOSFET as close to the one you selected that I had in my model file.
I reduced R1 to give the stated motor current (is it really 15A @ 3V?).
I also added an input stage to give a full 3V drive, since 2.5V is quite marginal for the gate voltage to fully turn-on the MOSFET.

View attachment 233198
Hello,
Thanks for your reply ,
Since this is push pull Gate driver so why voltage at gate is not 3V in your simulation and it is showing around 2.5V.

Thanks again !
 

crutschow

Joined Mar 14, 2008
27,718
Since this is push pull Gate driver so why voltage at gate is not 3V in your simulation and it is showing around 2.5V.
As Danko's reference notes, look at the difference between the output DC level of an emitter-follower versus the input DC level.
That will answer your question.
 
Top