Help needed regarding a relay module circuit

Thread Starter

Multinike100

Joined Oct 15, 2021
6
I have been following a youtube video and designed a circuit.
I have got them printed but it's not working, any suggestions providing details about how do I go about or where the problem lies is obliged.
Attaching images of schematics and pcb design.Screenshot 2021-10-15 212015.pngScreenshot 2021-10-15 212229.pngScreenshot 2021-10-15 212015.pngScreenshot 2021-10-15 212229.pngScreenshot 2021-10-15 212015.pngScreenshot 2021-10-15 212229.png
 

Thread Starter

Multinike100

Joined Oct 15, 2021
6
However i used the same schematics to power a 5v 10a relay and it works just fine, i'm guessing I messed up the circuit design somewhere but I'm not able to figure it out.
 

LesJones

Joined Jan 8, 2017
3,570
The relay will require a current of about 190 mA. Try changing the resistor to the base of the relay driver transistor from 10K to 1K
(I can't read the component numbers on your schematic.)This will increase the base current to the transistor but it is possible that the opto isolator will not be able to to turn the transistor off. This will depend on the current transfer ratio of the opto coupler.

Les.
 
Last edited:

Thread Starter

Multinike100

Joined Oct 15, 2021
6
Thank you, I had to replace the transistor, the transistor I was using was rated at 100 ma max, I had forgotten to take the coil resistance in calculating the resistor as well as as the transistor, both of the members who replied pointed that out.
Finally got it to work
 
Top