3phase BLDC motor driver

Thread Starter

aanaqzzz

Joined Oct 11, 2017
11
Hi to all,
I just want to ask regarding of the 3 phase BLDC motor IC driver which I use is APX9370,
when I build the circuit it seems there's no switching happening in the 3 phase out put of the IC, its like
the output voltage of the 3 pin going to motor is constant voltage , as my study to run or to rotate the motor should the
armature winding pole should be switching the voltage of each pole, but in my circuit its not happening can some one help to
discuss the wrong in my diagram?
 

Attachments

Thread Starter

aanaqzzz

Joined Oct 11, 2017
11
From the datasheet, this appears to be the circuit you are using as a model:
View attachment 152906

Source: http://www.datasheetspdf.com/pdf-down/A/P/X/APX9370-ANPEC.pdf

However, there are differences. In your circuit, you have OSC pulled high , not floating, and you have FG floating, not pulled high. Is there another source for the circuit you have chosen? Are those changes intentional?
Hi jpanhalt,

no , just follow this typical schematic from data sheet?
tnx ill try to pull high the OSC and float the FG?
 

jpanhalt

Joined Jan 18, 2008
8,344
Hi a,

You may have misunderstood my comment. This is what you show in your first post as being what you built:
upload_2018-5-23_5-0-57.png

Note, oscillator is pulled high and FG is floating. According to the datasheet they should be the other way around. In other words, what you built appears to be incorrectly wired. Double check what you built.
 

Thread Starter

aanaqzzz

Joined Oct 11, 2017
11
Hi a,

You may have misunderstood my comment. This is what you show in your first post as being what you built:
View attachment 152949

Note, oscillator is pulled high and FG is floating. According to the datasheet they should be the other way around. In other words, what you built appears to be incorrectly wired. Double check what you built.

Ow sorry for that, and thank you, ill check it again after I re design my board,
 
Top