Wheatstone's Bridge w/ thermistor, 741 op amp: output motor problems

Thread Starter

Mackatack8

Joined Jan 19, 2018
7
I'm designing a circuit to detect a slight change in temperature and activate a motor. I used a Wheatstone bridge, with one leg being a 10kohm thermistor shown in schematic below. The signal is then amplified with an 741 op amp. When I read the voltage output (delta V) from the op amp it is exactly as I want it when the temperature changes, about 0.6V. When I attach the motor (0.5V threshold) as shown, it does not work and the output voltage (delta V) now reads -7.2V. What is wrong? What should I try to fix the problem?

Thanks!
IMG_3326.jpeg
 

Alec_t

Joined Sep 17, 2013
12,007
A 741 can't source or sink enough current for driving a motor directly, unless the motor draws only a tiny current. You need a power output stage between the 741 and the motor. What that stage would be depends on the motor specification. What is the motor stall current at 3V?
 

Thread Starter

Mackatack8

Joined Jan 19, 2018
7
A 741 can't source or sink enough current for driving a motor directly, unless the motor draws only a tiny current. You need a power output stage between the 741 and the motor. What that stage would be depends on the motor specification. What is the motor stall current at 3V?
At 3V the motor draws 0.5A but does not stall. I can raise the voltage even higher - but I'm afraid I'll burn it out. I bought the motors cheaply online and have no manufacturing stats on them.

you mention a power output stage - Im not familiar with this term. Could I accomplish this through use of a relay?
 

#12

Joined Nov 30, 2010
18,217
Could I accomplish this through use of a relay?
Probably. I'd have to look up which 741, its current abilities, and the relay coil current requirement. Not a bad idea, but not completely baked. For instance, a 24VDC relay coil would require a lot less current than a 3VDC relay coil.
 

WBahn

Joined Mar 31, 2012
26,398
At 3V the motor draws 0.5A but does not stall. I can raise the voltage even higher - but I'm afraid I'll burn it out. I bought the motors cheaply online and have no manufacturing stats on them.
Which is a WEE bit more than the typical 0.025 A short circuit current spec on the 741.

you mention a power output stage - Im not familiar with this term. Could I accomplish this through use of a relay?
Your design implies that you want the motor speed to be related to the temperature difference. Is that what you want, or do you just want the motor to be switched on and off based on temperature?

Also, your design implies you want the motor to turn one way above a certain temperature and the other way below it.

It might help if you describe the problem you are trying to use this circuit to solve.
 
Top