UCC28740 flyback converter does not turn on

Thread Starter

reza4872

Joined Sep 12, 2020
21
Hi
hope you be well
i have designed a flyback converter using UCC28740 controller. design spec are listed below
input voltage: 24v (DC)
output voltage : 5v (DC)
output power: 3w
max freq: 100KHz
i have attached datasheet of ucc28740 and schematics of the converter.
my problem is that when testing the converter i have no output voltage. for an instance i have 4.5v (or something near that) on the output. after that the voltage starts falling to zero and stays zero.
controller generates no pwm pulse on DRV pin.
i have also tested the converter in open loop conditions (RFB2 , RFB5 and CFB1 are open circuit). again there is no pwm pulse on DRV pin.

i would be pleased if someone helps me
thanks a lot


also i tried to contact TI experts in E2E forums of ti.com
but i was not able to create any new question. (it keeps showing me an error) could you ask this problem there?
 

Attachments

ronsimpson

Joined Oct 7, 2019
1,227
Things that I have seen wrong: (things to check)
>Phase of the transformer.
>"HV" must be 24V or higher to start up.
>"VDD" no power. You can connect a external supply and force good power.
>remove OPTO to force to max duty cycle.
>some supplies are very unhappy with no load. Try 0.5 to 1 watt load.

Do you have a scope?
 

Thread Starter

reza4872

Joined Sep 12, 2020
21
Things that I have seen wrong: (things to check)
>Phase of the transformer.
>"HV" must be 24V or higher to start up.
>"VDD" no power. You can connect a external supply and force good power.
>remove OPTO to force to max duty cycle.
>some supplies are very unhappy with no load. Try 0.5 to 1 watt load.

Do you have a scope?
hi
thanks for your time

>> i am pretty sure that transformer phase is correct (you can check it with datasheet)
>> i have questions about HV pin. i even supplied it with 72v but controller did not work. can anyone ask this from ti.com (a can not contact them)
>> VDD is directly connected to 24v (input voltage). so i think VDD supply has no problem. i can not get what you mean by "VDD no power"
>> i removed opto once (open loop test - i removed 2 resistors and a capacitor as i mentioned earlier - FB pin is open circuit) but it did not have any effect. still no pulse on DRV pin
>> i will test the converter with a load. i will share the results with you
 

prepka

Joined Oct 5, 2020
13
If transformer phase not correct or diode backward chip will latch up after first pulse so look like not working. You will need scope to verify transformer phasing correct if you made yourself. Start and finish should be same if winding direction same. Try install power 24-36V only on vcc pin to the chip without power on fet to see pwm pulses coming out of chip. You need account to post on TI.com and win10 computer with up to date browser to post question and to use web bench software. You should try to simulate your circuit there or use the one it suggests. If one mistake in circuit then not working and need to debug.
 

Chunlei Sun

Joined Aug 25, 2016
3
Hi , I also building similar circuit, input 30vDC, the input voltage need exceed 65V then the circuit works. I saw TI reply tell the HV pin can work at 24V above. But it seems not likely.
 

Attachments

Chunlei Sun

Joined Aug 25, 2016
3
It is very hard to make a supply that works from 30 V to 265 V.

Why? at 30V does it start up but just not regulate?
The data sheet said it should start up above 21V.
Vin supply lower than 65v, observed voltage up and down at VDD pin, it tells a fault occur. Should be under-voltage lock out because when voltage above 65v then everything works. Refer to datasheet, I have confirmed on the resistance at VS pin and all correct, should work when voltage at 30V. Reality is NO. .. Not sure why, give up this IC.
 

prepka

Joined Oct 5, 2020
13
Primary inductance or turns ratio not correct for down to 30v operation. LP should be around 100uh and is about 60 for me. Gap probably not correct on ferrite core
 
Top