Trouble with the pump Voltage on my DIY Pic Kit 2 (Vpp Error)

Thread Starter


Joined Aug 8, 2015
My schematic is a lite version (doesn't include a voltage level detection nor is capable of programming a EEPROM).

So far I had build it on a breadboard using the exact components and their respective values except for the schottky BAT41 and the 680 uH inductance which are nearly impossible to find in my country (Bolivia) and used the 1N5817 schottky and a 570uH inductance instead.

The first time I test it I had this VPP error.

At least the PK2 Programmer does recognize it also I can download the firmware to the 18f2550. But I'm unable to use it to program anything.

I double-triple-checked the circuit on two different breadboards (no kidding). Still no success. I've changed the 2N3906 for a more stable pnp BC547 and the 2N3906 for another npn BC557. Same error as before.

I strongly believe the problem lies on one of four possibilities (hope it isn't all of them):

a. The quality of the components (most are from chinese origin, nonetheless I checked them one by one with a tester).
b. I double-triple-overlooked the same bloody error.
c. (This one is interesting) On all the photos of working circuits I've noticed the inductance is placed very close to a transistor (perhaps the npn?) is this a special configuration for the Vpp Pump Voltage? Do I have to find exactly the 680uH? Is 110uH much of a difference?
d. The transistors are causing the pump not to charge and maybe using MOSFETS will do.

I hope I've given you some clear idea of my problem and thank you beforehand.


Joined Aug 23, 2012
The other post in the projects forums that I already deleted.
I redrawn your circuit that it will be more easier to see the functions.

Where did get the charge pump circuit and how you calculate the values?
How is the values of C1(47uf?)?
The values of R4 maybe too high, you can change to 3.3K~4.7K.
You may try the L1=22uH and C1=0.1uF



Joined Aug 21, 2008
It looks like Microchip's circuit for the PICkit 1 & 2.

Ignoring losses, the output voltage across C1, Vo = 5 volts +(duty cycle of Q1 x 5V). Most likely the voltage is too low because one of the following losses is too high:

1. Most likely is that the resistance of L1 is too high. It should be the same resistance as the inductor in the PICkiit for which the firmware was written.

2. The saturation voltages of Q1 or Q3. Switching to the more familiar BC547 and BC557 might make this worse since they rated at lower collector current than the 2N3904/2N3906.

3. If D1 is not a Schottky diode with a low enough forward drop, that will add to the problem.

4. Anything else. When troubleshooting do not rule anything out until you have tested for it.