Treadmill stopped working

Thread Starter

jrcs

Joined Nov 9, 2016
17
Hi,

I have a treadmill that stopped working correctly. Whenever I plug in the power, it starts running very slowly and that's it. I can't change the speed, program, stop or start, etc.

I did disassembly everything and this was what I run into (attached files). I tested all the transistors with a multimeter and tried to test the zeners aswell. Couldn't find any problem.
IMG_20200515_174715.jpgIMG_20200604_150613.jpg
The motor power output indeed starts to have voltage but only if the control board is connected (by cable) to the power board which leads me to believe that the problem is in the control board. How can I solve this or look for the problem?
IMG_20200604_150620.jpg
Another thing, all the leads on the control board "converge" to the round black thing wich I don't know the name. Can somebody explain to me what it could be?
IMG_20200515_174702.jpg
Thank you all in advance.
 

Thread Starter

jrcs

Joined Nov 9, 2016
17
Hi Max,

Thank you for your answer but I was talking about the black round "thing" in the last attached file - where all pcb leads converge.
 

Duane P Wetick

Joined Apr 23, 2009
435
You have to buy a new PCB asbly. from the manufacturer. PLD programmable arrays are not repairable and they are the heart of the machine.

Cheers, DPW [Everything has limitations...and I hate limitations.]
 

Thread Starter

jrcs

Joined Nov 9, 2016
17
Hi Duane,

Thank you for your answer. The treadmill is a BH G-643/G-644. The problem is I can't even find the machine on the BH website or even in google images. Searching for "BH G-643/G-644 controller board" doesn't ring any bells.

If anyone could help, I'd be grateful.
Regards.
 

MaxHeadRoom

Joined Jul 18, 2013
23,369
Unfortunately that does not appear to be one of the more popular makes of T.M./Board etc.
You may find a spare board out there on Ebay etc, but it could also be an issue in the console etc.
Max.
 
Top