Treadmill blows fuse as soon as it starts

Discussion in 'General Electronics Chat' started by Bobisntabuilder, Sep 29, 2015.

  1. Bobisntabuilder

    Thread Starter New Member

    Sep 29, 2015
    Hi. I've got a Reebok treadmill that recently just stopped working.

    There was signs that something was wrong the last couple of times I used as it slowed down by itself and then went as fast as it could. I had to jump off to save myself from injury and then pull out the safety key to stop the belt going around. After the last time this happened the console works, the incline works but the belt doesn't turn.

    when I removed the cover and looked at the board I saw that the fuse had blown, so I replaced the fuse and then started the Treadmill. As soon as I did this the belt went round at full speed and then the fuse blew. so I ordered a few more fuses suspecting I had got the wrong type of fuse but, every time I replace the fuse and start the Treadmill it blows.

    I have tried unplugging out the red and black wires that come from the motor and then starting the Treadmill and when I do this the fuse does not blow. So I have looked at some other similar posts on here and tested the motor with a drill battery and it worked fine. However I did notice the ceramic green disc capacitor(see pic4) was cracked when I was trying to look for a fault. As soon as I pressed it, it crumbled. I do not know what type of capacitor this is, so I can not order a new one. I have no knowledge or experience with this kind of thing so I would appreciate any help.

    pic1.png pic2.png pic3.png pic4.png
  2. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    You need to check for shorted MOSFET or IGBT and bridge .
    You might need to check the motor for carbon deposits too.

    Your pictures are tiny, can't make out anything from it.

    The motor might run with lower voltage but still you need to check the carbon deposits and the brushes too
  3. bwilliams60

    Well-Known Member

    Nov 18, 2012
    If you don't have any knowledge of electrical or electronics, you could take the motor off and take it to an electrical motor rebuilder. They can tell you what is wrong with it and cost. You did well isolating the problem but it gets much more complicated from here on in.
  4. MaxHeadRoom


    Jul 18, 2013
    I doubt very much it is the motor, it can be tested on an automotive battery.
    I agree with @R!f@@ it is most likely a shorted Mosfet if it were a shorted SCR bridge component it would blow right away without even running.
    Is there any identification model on the board?
    Last edited: Sep 29, 2015
  5. Bobisntabuilder

    Thread Starter New Member

    Sep 29, 2015
    Hi, thanks for your responses. Sorry about the pictures, I'll try and get some better pictures up later.

    MaxHeadRoom the identification on the board is jd-230 f/f, if that helps.
  6. bbkpak

    New Member

    Sep 21, 2016
    Hi Bobisntabuilder,
    Did you ever resolve your issue?
    I'm having exactly the same issue and have the same board jd-230 f/f on a Smooth Fitness 5.25E treadmill.
    Originally I thought it could be the motor blowing the fuse, but now tested the motor with a battery and it runs fine. So maybe it is the controller board. Any suggestions welcomed.