TFT controller board firmware

Thread Starter


Joined Mar 4, 2014

At my work, before I came here, someone bought a 7" TFT LCD and it's controller board in the following link:

Some time later, one other guy, while working with it, let the LCD fall on to the floor and it broke. So, he went to a computer shop and the guy in this shop was able to provide a replacement 7" TFT LCD. However, this replacement LCD never worked with the controller and after researching for a while, I acknowledged that each controller board is kind of specific for each LCD model/reference/resolution.

This said, I cannot be sure if this replacement LCD is actually suitable for this controller board or not. Also, after researching a bit more on this subject, I learn that there are firmwares available for different LCDs and I was thinking about trying a few different firmwares and check if anyone would work with this replacement LCD.

So, to contextualize, I'll put here now some links and some info I could find about how to do what I wanted to do.
I found a site where they flash a firmware, I assume, to be able to use different LCD screens with the same controller board.
The link is:

The datasheet I could find of the controller board is here.

In the above link, long story short, the guy uses an old LCD he salvaged and flashed a firmware onto the controller and he manages to get it working.
He also says he forgot to backup his original firmware (from the control board).

So, first thing I wanted to do was to try to backup my original firmware from this PCB80099 v.9 board.
I'm using this RTD266x EEPROM Flasher software to read / write its memory and I can read it and save it into a .bin file.
What I don't know and need help to understand is that in this software, the write section (to save its EEPROM into a file) there is a field for the Start Address and Length and I don't know what to put in here so I tried to read from Length 256 up to 65536 and it never errored out. Only thing I noticed was that with 65536, there was a section in the middle of the saved file that was only 0xff and then, there was more data until the end.

How can I know what to put in these fields so that I know I have a usable backup of the original firmware?

Mods: Merge the image to this thread.


Another info I can give is that this LCD screen I have is not the original one as that one fall down and broke and someone bought a new one to try to use with this board and its reference is the following:
RFLK-FY7021D01H-3. 5Z-A08 D14011?
Last edited:

Thread Starter


Joined Mar 4, 2014
Well, after digging enough I managed to get it working.
I'll just leave here the final steps and result so that in future searches, if anyone comes across the same problem, can have some guidance on what to do and what to use, etc.

So, long story short:
LCD controller board is a PCB80099 v.9 also known as VS-TY2662-V1. A spec sheet can be found here.
The LCD that was purchased to replace the original one (a AT070TN94) was an LCD with reference RFLK-FY7021D01H-3. 5Z-A08 D14011, which can't be found much about it. But to be honest, the only thing really needed about it is its resolution which I could find here and it's 1024x600 in a google search. This resolution didn't match the original LCD which is 800x480. This said, a new firmware is needed for the PCB80099 v.9 so that the LCD can work correctly. Each LCD resolution needs a specific firmware, so, the original firmware on the controller board wasn't going to work.

I found a list of firmwares here and it was a matter or experimenting a few ones until I get to the conclusion that this LCD was in fact 1024x600 and by what was written in the silk screen of the controller board, a TTL firmware must be chosen. This said, I end up flashing this firmware and the thing worked (after quite a few flashes as trial and error, because at this point I still didn't know about the resolution and the TTL "small" detail).

I used a software called RTD266xFlash found here to flash the firmwares using the I2C bus available in the controller board and an Arduino Uno R3.

The resource I used was this site that tells you pretty much everything about the procedure.