SMPS higher secondary output than expected

Discussion in 'Power Electronics' started by mohan.n2293, Nov 14, 2017.

  1. mohan.n2293

    Thread Starter Member

    Jan 23, 2017
    54
    0
    Hi All,

    Myself Mohan N

    I,m i have designed a 3 phase power supply using TOP269E stackfet configuration,
    my spec for this is
    vin_min = 180v
    Vin_max=460v
    Vout1=5v
    Iout1= 10A
    Vout2= 6v
    Iout2= 1A

    Transformer info attached.

    here my issue is i'm not getting 6v output from transformer instead im getting "15v",please the transformer design once let me know if any changes required
     
  2. Dodgydave

    AAC Fanatic!

    Jun 22, 2012
    7,585
    1,250
    Post your circuit diagram, for better results..
     
  3. mohan.n2293

    Thread Starter Member

    Jan 23, 2017
    54
    0
    Please find my circuit and the power switch datasheet which i have used TOP269eg
     
  4. Dodgydave

    AAC Fanatic!

    Jun 22, 2012
    7,585
    1,250
    You have four outputs, one has a 5V regulator on it, which is a waste of time!! , the 5V rail is on the opto-coupler side should be regulating the chip, using the Tl431 zener, the resistors are set to 5V so where is the problem on your pcb.?
     
  5. Janis59

    Active Member

    Aug 21, 2017
    579
    92
    Sometimes it simply happens.
    Just yesterday I got in stupor when SMPS we was brewing few months long of 36kV and 4 Amps gave no voltage on load at all, but as I disconnected the dummy load, the Voltage was not an expected but plasma-ball through the 5cm gap. Still I wonder what it was, but only idea I may call not absolutely mad is that somehow I got the standing wave into transformer HV winding (hope I mistaking and reason will be more prost).
     
Loading...