pickit2 is not working

Thread Starter

Lim Joo

Joined Dec 10, 2016
7
i was trying to program my pickit2 with pic16f877a by using mplab and hitechC compiler. But when i tried to write the code to my pic, mplab showed this
PKWarn0003: Unexpected device ID: Please verify that a PIC16F877A is correctly installed in the application. (Expected ID = 0xE20, ID Read = 0x0)
So i decide dto troubleshoot my pickit2 and i found this. can anyone explain to me why?
 

Attachments

be80be

Joined Jul 5, 2008
2,041
The simple one get you a lot. Make sure you using the right pins mclr pulled to vdd with a 10 k data and clock power right.
and the crystal on right. i spent maybe 2 hours last night trying to get a simple led blink ti program.
it was bad bread board then i moved to a good one and crossed the data and clock wire because i had turned the chip around. its easy
to do backward. miss count a pin easy done.
 

spinnaker

Joined Oct 29, 2009
7,835
i was trying to program my pickit2 with pic16f877a by using mplab and hitechC compiler. But when i tried to write the code to my pic, mplab showed this
PKWarn0003: Unexpected device ID: Please verify that a PIC16F877A is correctly installed in the application. (Expected ID = 0xE20, ID Read = 0x0)
So i decide dto troubleshoot my pickit2 and i found this. can anyone explain to me why?
You do know you can take a screen capture on the PC right? What is with the horrible photo of your screen?

Is this a real pickit2 and not a clone?

Where is your schematic ?

How are you powering the Pic?

How do you have things wired up? Is it a PCB? If so where did you get it? Is it a breadboard?

Do you have another Pic available to try?
 
Top