PICkit 3 suddenly stopped working

Discussion in 'Embedded Systems and Microcontrollers' started by Filipe Martins 2, Jul 26, 2018.

  1. Filipe Martins 2

    Thread Starter New Member

    Jul 26, 2018
    1
    0
    Hi everyone,

    Currently working on a project using the PIC12F1572 microcontroller with MPLABX IDE and PICkit 3. Everything seemed to go well so far, as I managed to start to code and also test my application on the target. Both debug and release modes were working without any issue, when suddenly the IDE console returns the following error message when trying to program the microcontroller, using an external power supply:

    Connecting to MPLAB PICkit 3...

    Currently loaded firmware on PICkit 3
    Firmware Suite Version.....01.52.02
    Firmware type..............Enhanced Midrange

    Target device was not found (could not detect target voltage VDD). You must connect to a target device to use PICkit 3.

    When configuring PICkit 3 to supply the circuit, the following message pops up:

    Connecting to MPLAB PICkit 3...

    Currently loaded firmware on PICkit 3
    Firmware Suite Version.....01.52.02
    Firmware type..............Enhanced Midrange

    Programmer to target power is enabled - VDD = 5.000000 volts.
    Target Device ID (0x3fff) is an Invalid Device ID. Please check your connections to the Target Device.

    Device Erased...

    Programming...

    The following memory area(s) will be programmed:
    program memory: start address = 0x0, end address = 0xdf
    configuration memory
    program memory
    Address: 0 Expected Value: 281c Received Value: 3fff
    Failed to program device

    Notice the connections between microcontroller <> PICkit3 were not changed and I have 3 sample PCBs returning the same error. I've also followed this post but nothing seemed to work. Any clue what should I do so that my setup comes back to life?

    Many thanks in advance.

     
  2. jpanhalt

    Expert

    Jan 18, 2008
    7,159
    1,574
    Welcome to AAC.

    Several years ago, before PK4 came out, I had a similar problem with a PK3. Called Microchip in Chandler and it was replaced with a new one. Had to return the bad one. Then Microchip gave me a nice discount on an ICD3 and let me keep the brand new PK3 too. Shipping was FedEx overnight, so it was quicker than trying to solve the problem.

    I would call Microchip and see whether it can help.
     
    absf likes this.
  3. Raymond Genovese

    Well-Known Member

    Mar 5, 2016
    1,643
    989
    I have had my share of some bizarre problems with PK3. One "tip" that you might try and I don't think it is in that thread, but I do recognize that thread.

    Try programming it with PK3 providing the power and, of course, with the chip only and making sure you have Power Target Circuit From Pickit 3 checked.

    Then go to this screen:

    Untitled-x.jpg

    and change to Manually Select Memory and Ranges. If the correct range appears, try to program it with that setting. This worked for me with a 10F Pic that wanted nothing to do with programming. But, that worked! Then I reset it to Pic selects and have lived happily ever after (so far).

    I don't know if it will help you, but it is worth a try.

    Edit: I also have had to hold the PK3 button down throughout the programming to get it to work - and once it did, I wouldn't have to do that again (likely some failed reset issue).
     
    absf likes this.
  4. MaxHeadRoom

    Expert

    Jul 18, 2013
    17,911
    5,477
    I have continually had problems with Pickit3 compared to Pickit2.
    I have to go strictly through the procedure as laid out by picmicro sheet as to to the sequence of power up and plug in the pickit.
    a real pain.
    Max.
     
    absf likes this.
  5. be80be

    AAC Fanatic!

    Jul 5, 2008
    1,768
    347
    The problem with the pickit3 is forget trying to power with it the dam thing doesn't have enough juice to power anything over a bare chip
    with nothing hooked to it.
    If you don't set to power on on a bare chip it will error..
    You have to power target from the start then program chip if you do it after it looks for the chips you will get a error

    I power my chips I have not had any problems after doing so.
    I loved the pickit2 it just worked.

    Got a pickit3 for these newer chips it would always mess up till I unplugged it powered the chip at right voltage and I have not had any problems
    after.
     
  6. Picbuster

    Well-Known Member

    Dec 2, 2013
    900
    117
    I never use the pk3 as a power source for my boards.( unmodified USB 100-200mA max your hardware + programming could pop over the I max threshold, voltage drops and pk3 goes in error mode.)
    Disadvantage I have power-up my own electronics allowing to program.
    Never had any problems 100+ small projects 1500+ times programming.
    pic 12f, 16f, 18f and 24f projects.

    Picbuster
     
Loading...