Need Advice About Problem With USB Stick

Thread Starter

Glenn Holland

Joined Dec 26, 2014
649
I am using a Kingston G3 USB stick on my Windows 7 computer.

However, I am experiencing the following problems with this particular USB device.

(1) The computer does not respond (or recognize) the USB stick after plugging it into a USB multi port hub and sometimes it takes about a minute before the normal Kingston file list appears.

(2) Other times, I get a message that says the USB device must be scanned for problems. So I run the scan and the normal file list is finally displayed.

(3) Sometimes, the reading process continues for about a minute and some files cannot be accessed. The light on the stick keeps blinking and the Windows Task Manager indicates the drive is not responding.

However the other devices (a mouse and the keyboard) that are plugged into the USB hub are working OK. I have several other USB sticks that do not experience any of these problems. Therefore, the problem is isolated to the particular USB stick itself. Is there any way to fix this or should I try to copy all the files off this device to another location and drop it in the "round file"?
 

SLK001

Joined Nov 29, 2011
1,493
I have fixed many a Kingston USB stick because of bad regulators. However, the price of a new USB device is under $10 for a 32 GB device, so why bother fixing. I agree that you should get the files off and CRUSH it (or, tear it apart and see if you can fix it). Remember that it is a storage device. If you trash it, someone can still get sensitive files off the device.
 

Thread Starter

Glenn Holland

Joined Dec 26, 2014
649
here's an update on this problem.

I plugged the USB stick into a copier at a neighborhood printing shop and I was able to open most of the files with no problem. However several files that could not be opened on my home computer were also unopenable on the copier. So there is something wrong with the stick. if I get lucky, I can copy the files to another stick and get rid of the old one.
 

BobaMosfet

Joined Jul 1, 2009
782
Look at your properties of the drive under My Computer, and do a fix-disk on it. If it can it will try to find all the blocks and relink them together. Then see if you can open the files on your computer and copy them elsewhere (back up).
 
Once my computer didn't recognize the boot disk (USB)I created,i think i made a mistake,in fact,it worked fine on another computer,but not on mine.You'd better make a new one again.
 
I just had a similar problem. I got an archive of a magazine from the publisher. It rarely mounted on my Linux machine. It did not mount on a machine at Staples. It mounted on a copier at staples.

So, for fun I used a USB active extension cable or a USB hub and all was fine.

The publisher warrants the data and not the stick.

In your case, I would make sure that the power supply for the USB hub is capable of running all devices at their respective currents.

Get the data off and toss the stick.

Part of my problem was the geometry.
 
Top