Is this mosfet dead? Strange behavior

Thread Starter

Clinteastwood1

Joined Apr 2, 2021
14
Hi,

I am trying to troubleshoot a laptop's motherboard, I measured the resistance of the 2 entry mosfets, and the second one seems to have a weird behavior.
As a matter of fact, it has an infinite resistance (meaning it's dead, right?) but when I measure its voltage it shows 19v as the first one, as if it was fine...
So is it dead or my method to detect dead mosfets is crap?
( I tried with the diode mode of my multimeter, it also shows there is a discontinuity)
Thanks for your help guys.
IMG_20210405_154121.jpg
 

wayneh

Joined Sep 9, 2010
17,031
I don't believe that an in-circuit test is definitive. It might warrant taking the time to remove the suspect part, but don't be surprised if it's a dead end.
 

Thread Starter

Clinteastwood1

Joined Apr 2, 2021
14
Mosfets seem a mess to test, I saw videos where they seem fine and in fact they are faulty... A guy told not to rely on the multimeter values because you can be tricked, sometimes you think you measure the mosfet but in reality you measure another part of the circuit... so he told to analyze the whole circuit to make a decision, which I am not capable of due to my limited knowledge in this field.
I am more and more encline to change all the mosfets on the board since these parts are cheap, so I won't scratch my head all day long to find which one is dead. But there are a dozen and I've never changed one haha. I guess with some Flux it should be fine.
But I would have been glad to know how to measure them for sure.
 
Top