Installing External Libraries

Thread Starter

Yarmond15

Joined Aug 28, 2020
14
Hey all,
So I'm brand new to programming and am stumbling my way through a project and was hoping to find some assistance, please bear with me. I am using a pre-made code from a zip folder (that is now extracted of course). The code was designed to be used with the software "Processing". I downloaded the software and opened the code. I am encountering an issue there are libraries in visit file, but I am unsure where to copy them in order for them to be read by the processing program. Advice?
Thanks ahead of time!
 

Papabravo

Joined Feb 24, 2006
14,399
Hey all,
So I'm brand new to programming and am stumbling my way through a project and was hoping to find some assistance, please bear with me. I am using a pre-made code from a zip folder (that is now extracted of course). The code was designed to be used with the software "Processing". I downloaded the software and opened the code. I am encountering an issue there are libraries in visit file, but I am unsure where to copy them in order for them to be read by the processing program. Advice?
Thanks ahead of time!
Every program id different. You're going to have to reveal more details in order for us to have any chance of helping you.
 

Thread Starter

Yarmond15

Joined Aug 28, 2020
14
Every program id different. You're going to have to reveal more details in order for us to have any chance of helping you.
Got it, that makes sense. Would you be able to explain more specifically which parts need more explanation? here are pictures of the error message, the folders in the Processing application folder, and the folders found in the "Library" folder in the Zipped folder.
 

Attachments

Thread Starter

Yarmond15

Joined Aug 28, 2020
14
It is a total mystery to me what you are working with. I have no clue how to help you.
Ok, I can attempt to explain it a little better. I am working on this project: https://www.instructables.com/id/Nerf-Vulcan-Sentry-Gun/
I am on step 11 and I'm not sure how to proceed. I downloaded the Processing IDE as well as the Folder with the codes as instructed. However, when I try to run the code provided to me, I get the errors in the above response.
 

mtonge

Joined Apr 19, 2016
90
I just looked at the Instructable, pretty cool. Since the brain is an Arduino, why are you using the Processing IDE instead of the Arduino IDE?
 

Thread Starter

Yarmond15

Joined Aug 28, 2020
14
I just looked at the Instructable, pretty cool. Since the brain is an Arduino, why are you using the Processing IDE instead of the Arduino IDE?
Great Question! I'll check out the link. Main reason being that it told me to use the Processing IDE, so I did. Without any coding knowledge, I'm not confident enough to make changes on my own...
 

Thread Starter

Yarmond15

Joined Aug 28, 2020
14
Okay, update. I was able to upload the libraries by dragging the folder titled "libraries" into the processing folder in my documents section of my computer! Now I am encountering a different issue. I'm getting an error message that one of my libraries is not recognized. I attached two images, the first is of the error message and the area of the code where the error occurred, and the second is the file path that proves that my document is in the correct place. Any recommendations for insight as to why there is an error? I tried uploading the code into a 64 bit program, but that did not work (it told me the code had to be run on a 32 bit program).
 

Attachments

Top