How to test the HT12E/HT12D & Tx/Rx 433 MHz RF Module

Thread Starter

mkbutan

Joined Sep 30, 2008
277
i have checked the RF 433 Tx/Rx its working .
sorry i don't have the oscillsocope?
 

praondevou

Joined Jul 9, 2011
2,935
Ok, so you say the data outputs of the HT12D are correct, right.

In your schematic there is one big arrow showing the connection from HT12D to the development board.

Did you connect it correctly, can you post the link to the development board etc.?

If you want other people to respond you will need to give a good, detailed description of the problem.
 

Thread Starter

mkbutan

Joined Sep 30, 2008
277
yes its as follows

IC 2 => Development Board
HT12D => μc (P89v51RD2)
pin 10 => pin 01/port P1.0
pin 11 => pin 02/port P1.1
pin 12 => pin 03/port P1.2
pin 13 => pin 04/port P1.3

__________

the LCD shows "EFY
Water Level LOW,25%,100%(50%,75% not working (have to check the Tr. BC547, that today i will replace it with the new one's))
__________

sir,
the program D/L from the site is in *.asm/*.lst/*.hex can the same code's can be written in "C" language as i am learning this language.
__________

and the same ckt. can be used to operate the pump, with some add. modification with the help of RELAY's
 

praondevou

Joined Jul 9, 2011
2,935
Can you test the development board/LCD without the whole rest?

Just by changing the 4 input signals to it?
 

Thread Starter

mkbutan

Joined Sep 30, 2008
277
hi
finely the ckt is working
now can any body guide how to upgrade it with auto ON/OFF
there are still 4 ports ideal (P1.4;1.5;1.6;1.7)
 

Thread Starter

mkbutan

Joined Sep 30, 2008
277
what should be the element/ material for the water sensor (is SS is good) for the water sensor.
 

Attachments

Top