Help needed with fault PWM AC Motor Speed Controller

Thread Starter

Meeko

Joined Feb 28, 2024
4
Hi all,

I'd be very grateful for any help. I have a Dual Action Polisher from a company called Maguiars and it's a very common fault that the speed controller fails. The symptoms are the motor speed increased and decreases, and seems to work most consistently at a higher speed. From my research, the speed is controlled by a PWM AC Speed Control circuit board (picture included). Would anyone know the most likely failed component to cause this sytmptom? Would it be the MOSFET?

Thanks in advance!
 

Attachments

Thread Starter

Meeko

Joined Feb 28, 2024
4
Hi Dave, thanks for your reply. Plese find better pictures. The issue is intermittent - sometimes it functions as expected, other times the motor speed is erratic, sometimes running way too fast.IMG_7475.jpgIMG_7476.jpgIMG_7472.jpg
 

schmitt trigger

Joined Jul 12, 2010
904
I would also suspect the variable resistor being at fault; either due to wiper contamination or a solder joint becoming intermittent.
If the main Mosfet were at fault, it would be shorted and the device would run at full speed always.
 

MisterBill2

Joined Jan 23, 2018
18,568
Most component faults are not intermittent. So the variable control is certainly the first suspect. Other possible causes would be a failing solder connection or contamination causing electrical leakage. leakage The solder joint near the "R4" label looks a bit suspect, but that might be just a lighting issue.
 
Top