Thread Starter


Joined Apr 23, 2021
I am trying to convert HDMI to LVDS using Chalkboard-electronics adapter (https://chalk-elec.com/?page_id=1283#!/HDMI-to-dualLVDS-converter-FullHD/p/42489709/category=3094859).
Schematic is available in the link (and also attached), although there is a small error; "PIXS"-pins of the TFP401 is not GND'ed as in the schematic, but actually VDD'ed on the actual board (configures TFP401 to 2 pixels per clock instead of 1 pixel per clock).

Basically the idea is that the HDMI is converted to 24-bit RGB through the TI TFP401 (48-bit in practice, as it is configured as 2 pixels per clock, via the PIXS-pin), which is further converted to LVDS (OpenLDI, I guess) through the DS90C387A.

Basically no matter what I try, the screen stays black (I toggle background light through another independent PCB and I easily see whether backlight is on or off - but there's no image on screen).

Now, I have checked the basic configuration pins of both IC's, and they match the schematics and both Hsync-, Vsync-, Pixel clock- and DE-signals are present and look alright at first glance (mind you, I am not a digital video expert!).
/Power-down pins controlled by PIC processor are both high.
RGB-data seems present on all 48 RGB pins between the ICs and differential signals are present on LVDS output. I cannot decipher the signals, but the clock-lanes are definitely clocks and data lanes looks like data - I have also verified pin-out/connection between board and display twice.
CM level is good (approximately 1.2V) and DM-signal are roughly 400mV, although this is measured using a standard 500MHz probe, so actual values may vary.
To be certain signal strength is okay, I increased to LVDS power form default (0.75V) to 1.5V with a 9k resistor from VDD to PRE_pin of DS90C387 - still no image on screen.

The display (1080p @ 60hz) I am using is this: https://media.digikey.com/pdf/Data Sheets/Data Modul/eTD133W3202-AUA-A.pdf
I have attached EDID information of (on of) the file(s) I have tested with the display - it's is from another board that does work with the display, but is using DVI instead of HDMI; I have of course also tried changing the DVI configuration in EDID file to HDMI, but to no avail.
... attached EDID data in readable text-format decoded using "edid-decode" in Ubuntu.

For testing purposes I have attached the display and adapter board to Windows and Ubuntu, but also to a Raspberry PI Compute module w/ IO-board with the following configuration in /boot/config.txt:

I have not plugged-in the board's USB connector or in any way tampered with the onboard PIC-controller/firmware.

Does anybody have an idea of what I am missing?
Configuration of data-format, EDID-errors etc.? Like stated I am not an expert, in fact this is my first time ever tampering with display interfaces....




Joined Sep 21, 2016

Did you happen to figure out what the issue was? I find myself in the same situation using the same adapter. No matter what I try, I only get a black image.