Having problem with my amplifier

Thread Starter

Mtz mohsin

Joined Dec 18, 2020
6
My amplifier sounds after few hours of rest what may be the cause? It's a old victor ax v909 Av master. Everything else is working perfectly but the problem is when I switch off while its working and then turn it on again there is no sound come out from the speakers until it gets rest for a few hours then it will work perfectly. Can anyone here please help me to resolve this issue?
 

Attachments

MrSoftware

Joined Oct 29, 2013
1,956
My first guess is there might be a bad or cracked solder joint that closes up after it gets hot. You can try turning it on and when it will not play gently press on things with something non-conductive like a pencil, see if it will suddenly turn on when you press any one component. That might help you narrow down the cause. Another option is turn it on then start gently warming some areas with a hair dryer and see if that makes it come on.
 

Thread Starter

Mtz mohsin

Joined Dec 18, 2020
6
My first guess is there might be a bad or cracked solder joint that closes up after it gets hot. You can try turning it on and when it will not play gently press on things with something non-conductive like a pencil, see if it will suddenly turn on when you press any one component. That might help you narrow down the cause. Another option is turn it on then start gently warming some areas with a hair dryer and see if that makes it come on.
Sir thanks for replying... there are lots of components inside I am confused which sections I have go check I think it may be the pre amplification section or some other because speakers relays are working perfectly but the problem is with the signal I think so please advise me which area I will chek for the week soldier joints?
 

MrSoftware

Joined Oct 29, 2013
1,956
From here I can't tell you which part to check, so just start on one side and work your way to the other. You should be about to touch almost everything in just a few minutes. Just be sure whatever you use is non-conductive, like a wooden pencil, so that you don't accidentally short anything or shock yourself.
 

Sparky-Gary

Joined Dec 30, 2020
1
My amplifier sounds after few hours of rest what may be the cause? It's a old victor ax v909 Av master. Everything else is working perfectly but the problem is when I switch off while its working and then turn it on again there is no sound come out from the speakers until it gets rest for a few hours then it will work perfectly. Can anyone here please help me to resolve this issue?
Sounds to me like the power transistors are getting hot and will not latch back up when hot and need to go through a cooldown cycle before they will latch back up and allow current to flow through them, might need to be replaced or have new thermal compound placed on the heatsinks....maybe? Get a infrared heat monitor and see what is getting hot...this might help locate the problem. https://www.homedepot.com/p/Klein-T...7EIHh3WHWTvKcZpJ4fBoCQmMQAvD_BwE&gclsrc=aw.ds
 
Top