Error using arduino as ISP for burnning bootloader, keep getting, programmer not responding, not in sync

Thread Starter


Joined Aug 1, 2022
I have been trying to burn bootloader to an attiny85 board using arduino as ISP, and i have been getting this below error. Previously when i encountered with this error(previous projects) usually the TX would been communicating through serial monitor, so i couldn't upload the sketch, and would get the same above error. As a solution to that i would release the reset button as soon as i click the "upload sketch" and it worked!. But this time as was using an 10uf capacitor to stop arduino from resetting, there was no point in pressing the reset button. I also tried to upload a simple blink sketch before burning bootloader, so that the Tx remained off. But still the problem persists. I have never done this before and new to this.

arduino UNO, IDE version 2.0.3.

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x03
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x03
Failed chip erase: uploading error: exit status 1


Joined Jul 10, 2017
I recently had this problem and it was because I had not uploaded the 'ArduinoISP' sketch into the programmer arduino.
You have to remove the 10uF capacitor from the Arduino reset line before you load the Arduino isp sketch into it. Then you replace it to use it as a programmer.
Last edited: