Delaying a square wave by 1us

Thread Starter

hoyyoth

Joined Mar 21, 2020
192
Dear Team,

I have a square wave total pulse width of 30us(15us on and 15us off) and an amplitude of 3.3V.

I need to delay it by 1us. I am using LTC6993 for this purpose. This is the link for the calculator (http://beta-tools.analog.com/timerblox/LTC6993).

When I simulated the circuit I can see that the pulse width of I/P and O/P is different.May I know why

Attaching my simulation file here . Please change the .txt extension before using it.

Please let me know can we implement this in any other way.

Regards
HARI
 

Attachments

ericgibbs

Joined Jan 29, 2010
14,712
hi HARI
This what I see with LTS, as you say the pulse width is reduced.
I now have the d/s for the device, see what I can suggest,
E
BTW: you can upload directly to AAC asc file extension, no need to change to txt
EG 957.png
 

Thread Starter

hoyyoth

Joined Mar 21, 2020
192
Hi Eric,

Thank you very much.
When I used LTC6994-2, my issue is resolved. This IC will delay both rising and falling edge.

May I know any other options to do the same.Can we use any opamp based circuits.

Regards
HARI
 

ericgibbs

Joined Jan 29, 2010
14,712
Hi HARI,
Checking the d/s suggests the LTC6993 device will work as you expect, look at page #21 for an option using two devices, to restore the original pulse width.
E

Added:
Please post your LTC6994-2 version asc.
 

crutschow

Joined Mar 14, 2008
28,551
I have a square wave total pulse width of 30us(15us on and 15us off) and an amplitude of 3.3V.

I need to delay it by 1us.
How close do the rise and fall delay need to match?
Or how much difference can you tolerate between the on pulse-width and the off pulse-width?
 

Thread Starter

hoyyoth

Joined Mar 21, 2020
192
Hi Curtschow,

Thank you very much.

We are the initial stage . Now just we need to delay the signal from 1us to 30uS.
I am able to do it using LTC6994-2.
I am exploring other options to implement the same.
May I know your thoughts.

Regards
HARI
 

Thread Starter

hoyyoth

Joined Mar 21, 2020
192
Dear Team,

I used LTC6994-2 for delaying pulses.I provided a delay of 1us

I can see that at the output some of the pulses are missing.May I know why.

Please see the below image.

1635400664810.png

Regards
HAri
 

Thread Starter

hoyyoth

Joined Mar 21, 2020
192
Hi Eric,
I need full pulses at the output.My expected I/P output waveform is given below
1635416932148.png
Regarding
Hari
 
Last edited:

djsfantasi

Joined Apr 11, 2010
8,078
Is it possible to connect a series of gates, so that the total propagation delay time is 1us? At 5V, eight NAND gates in a CD4011 will give close to the desired delay.
 

ericgibbs

Joined Jan 29, 2010
14,712
Hi,
The TS has been give a simple option in post #6.
Perfect alignment shown in post #7.
But now complaining of missing pulses, on his original circuit, asked him where and how many, still waiting for an answer.

E
 
Top