Board game console circuit board not working

Thread Starter

Sande11

Joined Jan 1, 2020
1
I’m going to try and describe everything to the best of my knowledge. I apologize, as I’m a novice trying to learn as I go.

I have the console to an old board game – when working it talks you through the game, there is a on/off button and four additional buttons that you use throughout the game. The batteries corroded in it years ago and it has sat on a shelf for many years not working. When someone asked if they could play it recently I started tinkering with the console trying to get it to work. After cleaning the contacts in the battery compartment (4 AA batteries) thoroughly I used a multimeter and discovered that the electric current was not reaching the circuit board. Cutting the wire off where it was connected to the battery compartment, cleaning and re-soldering the wire back into place on the battery contact solved this issue but the console still wouldn’t work.
With the multimeter I checked the wires where they connected to the circuit board and got a reading so I knew the electric current was at least reaching the circuit board. After watching some YouTube videos on the basics of circuit boards I started tinkering with it trying to make sure everything was attached, etc. By luck I started with the resistor that seemed closest to the on/off switch contact point. The resistor seemed connected fine but when I took my screwdriver and touched the solder point on the backside of the resistor (yellow arrow in photo A) the console came to life and began as it should when the on/off button is pressed! Unfortunately when I put the console back together and pushed the ‘on’ button nothing happened.
Normally the console will power off after 5-minutes of inactivity or one can press the on/off button to turn it off so clearly this button isn’t working. I took it apart again touched the same spot with my screwdriver and it again came to life. This time, since it was now on I placed the rubber buttons over the circuit board and let the game run its course, I discovered the four other buttons (photo B) worked, it is just the on/off button not working. Since it was on we were able to put everything back together and play a few rounds. When we were done it powered off after 5-minutes.
Later I tried to get the console to start up again by touching my screwdriver to that spot on the circuit board – nothing. I tried the opposite side of the resistor and got a tiny spark but nothing else. I walked away for an hour or so and when I went back to try it again upon touching that spot on the circuit board with my screwdriver the speaker made a quick crackle but that’s all, I can’t get it to turn on. With my limited understanding of circuit boards the issue seems to be connectivity at the on/off switch but maybe I’m wrong. Any ideas on what I should try next? I’ve included a photo of the components (photo c), the resistor standing alone in the center/right of the board is the one I was touching my screwdriver to the soldered (southern) backside of to get it to work earlier. Thank you!
 

Attachments

Wolframore

Joined Jan 21, 2019
1,536
Looks like the traces near the pads for your on button and the one left of that have some damage and corrosion. It’s difficult to tell whether this can be repaired. Sometimes a small strand of wire can bridge where there are issues. I hesitate due to this being button pad. If you have a multimeter check between the traces and thar Resistor and see if it has continuity.
 
Top