BISSELL Handheld Vacuum Cleaner not turning on

Thread Starter

vessosa

Joined Jan 25, 2021
2
I have an old Handheld Vacuum Cleaner that worked a few times after I moved from Spain to the US, but now it won't turn on, and the LED is red (for a few seconds, and then the LED turns off). When the charger is plugged in, the LED indicator remains green continuously, indicating a full charge; this vacuum doesn't work when plugged in.

After opening the case, I suspected the battery might be the problem. I bought a new one, but the issue persisted. I returned the battery and began considering alternative solutions.

The battery voltage was measured at 15.7V, which is higher than the specified Li-ion 14.4V 2000mAh/28.8W. I guessed (no experience here) that this may be an overcharging problem, so I tried to discharge the battery to reach a level below 14.4V. I have no "Battery Balancer" tool, so I took the DC motor and plugged it directly into the battery for a while (measuring with a multimeter). After a while, I got the desired level, but the same problem persists.

From my last test, I could check that the DC Motor works (Model d3648d-f 14.4V 80W).
The circuit board seems fine. (see attached both sides)

Can you suggest how to proceed next? The manual doesn't mention anything about the red LED. I tried to contact BISSELL, but haven't received any response yet. I was considering buying a Battery Balancer to check and possibly charge the battery at the right voltage and amperage, but I'm not sure if it's necessary.
 

Attachments

Top