Battery pack only charges with low current charger

Thread Starter

fokcuk

Joined Jan 28, 2011
1
Hi everyone
A lot of unknowns in the question, just need to know where to look.
I have a small battery (3.7v 2p1s 18650 pack) powered projector. Recently had the battery pack rebuilt by someone else as I don't have a battery welder. It worked great, twice the battery life (original was rated 3000mAh and new one is almost 6000mAh).
Problem appeared when I tried to charge the battery through the inbuilt projector mini usb charger. It starts charging fine, current draw increases to around 1A, then the charge stops and current draw drops to 0.01A. If I unplug the charger, it starts charging again for a few seconds and then stops.
To get the battery charged I had to use an old 500mA usb charger instead of any newer ones that can do 2-3A. It actually charges at about 700mA but charges ok.
So... I am trying to find where to look. Since I don't have the original battery pack anymore and the guy who rebuilt it does not respond, I am just guessing that it must be a protection of some sort.
Is it likely that the charger circuit on the mainboard is bad or there is some sort of protection on the battery side?
Need to think where I can put a current limiter so that any usb charger will work
 

Yaakov

Joined Jan 27, 2019
3,464
It sounds like the battery protection board is cutting the power due to the current being applied. If we guess the protection uses the ubiquitous DW01, then the voltage on the CS (Current Sense) pin shuts down the charge until the battery is disconnected and reconnected.

The solution would be to replace the protection board with something that can handle an amp or more, if the batteries are rated for that charge.
 
Top