Windows 7 now not recognizing Arduino, but did previously

Thread Starter


Joined Mar 18, 2015
My arduino uno (purchase directly from uno store, not a bootleg) was working properly a few weeks ago.

Mega 16U

Upon first install, I connected the uno via usb and the software installed automatically. I didn't have to do anything else.

I connected the uno today and it tries to install the driver, but fails.
On my Windows 7 machine, device manager shows other devices>Unknown device.
If I search automatically, it cannot find any drivers
If I browse my computer and search in "C:\Program Files (x86)\Arduino\drivers", it states could not find driver software even though the arduino.inf file is indeed there.

If I choose "Let me pick from a list of device drivers", I choose Ports (COM & LPT), choose have disk and browse
to "C:\Program Files (x86)\Arduino\drivers" and choose arduino.inf, then the arduino uno model.

Prompted with "Installing this device driver is not recommended because windows cannot verify that is is compatible with your hardware". Proceeding, software installs, but fails to start "This device cannot start (Code 10)

I tried different versions of IDE
I deleted all unused COM ports
Used another USB cable, made no difference
I tried installing on another machine (Windows8 ) with the exact same errors.


Joined Apr 11, 2010
I had the same problem, but couldn't fix it until I upgraded to Windows 10... I am running 1.6.5 of the IDE (1.6.6 has serious bugs). If you had 1.6.6, try 1.6.5 first.