Triac not working when controlling induction fan.

Thread Starter

idrbur

Joined Jan 11, 2018
43
I am trying to to control a induction motor(fan) using a triac and MOC3021 but so far i've ruined 2 triacs trying to do so.
I am using the given circuit but instead of 50 ohm i am using a 1000 ohm resistor and intead of 10nf i'm using a 1 nf capacitor.
The circuit worked fine with other ac loads but on my first try without snubber circuit the circuit worked fine for about 1 hour then the fan started running at full speed.
Then i added the snubber circuit but as soon as i attached it to the fan, fan started making very humming noise and started running at a very low speed i can still control the fan speed using pwm but it never stops. Even when signal is zero it makes humming noise and keep running very slowly.
Can anyone tell me what i'm doing wrong and a better method for controlling the fan.
Thankyou.

UPDATE:
I just wasted one more triac trying and found out that the triac started behaving wiedly after a power cut occured and the fan switched from mains supply inverter supply.
Before that it was working perfectly.
Is it possible that inverter supply id responsible for this?
images (3).png
 
Last edited:

MaxHeadRoom

Joined Jul 18, 2013
25,212
I am guessing it is a shaded pole motor?
These should be started at full RPM when used with a TRIAC etc.
They do not control well.
Also you have to control it from 50hz/60hz.
 
Top