Toshiba tv

Thread Starter

Ac2OB

Joined Nov 2, 2017
12
I have a Toshiba 22av500u TV that was manufactured in 2008. Florescent screen not LED. The TV will operate normally if I turn it on for a minute then turn it off and then immediately back on. Otherwise it turns on with various patterns of gibberish on the screen or with some random menu on screen. Any ideas on where to look first?
Also I have been down the rabbit hole on the net trying to find a schematic for this thing. So far no joy. I know TV's are extremely inexpensive these days but that's not the point. I would like to repair this thing, especially since I am home hiding from the corona virus. Any help will be greatly appreciated.
 

wayneh

Joined Sep 9, 2010
16,390
I'd look at the power supply, partly because it's a likely suspect but also because a successful repair is more likely if it's the PS. The last couple I repaired both used 12V switch-mode power supplies that were easily bypassed with a generic 12VDC adaptor (with a properly hefty current rating).

It sounds a little like the voltages haven't come up and stabilized when the TV boots. Rebooting the TV after the PS is warmed up works for now.
 

bwilliams60

Joined Nov 18, 2012
1,311
I agree with @wayneh as to startingnwith the power supply. Generally all the voltages are stamped on the PCB beside the connector. I would only suggest doing this if you have a good knowledge of power supply safety as the voltage in thi set could cause personal harm or death if you get poking around in the wrong places. Check your PS readings and get back to us. Also check all of the electrolytic caps for any bulging or damage. I will see if I have a diagram for this set later in the day
 
Top